kdesu dolphin problem

while i do kdesu dolphin /ANY_DIRECTORY it only opens the dolphin window with no contents of the folder, there is a message displayed at the bottom, which says,
“Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files.”

whats goin on here?:confused::cool:

I have the same problem. I even can’t open a trash from the desktop with the same error.

dolphin and konqueror are borked at the moment, at least for me in 4.0.4

try starting from a terminal and see what error you get
in term type: dolphin
or konqueror

I’ve found that only one (Konqueror or Dolphin) can run in Super User mode at a time (can extend beyond sessions).

If Dolphin won’t run, then use Konqueror.
If Konqueror won’t run, then use Dolphin.

Unfortunately, I haven’t yet found a way to launch Konqueror File Manager from the Launcher or command line yet, when you launch Konqueror without any switch, it defaults to the web browser.


OK, when I start dolphin from console with a root it’s start and works, but I see the next:
Maxoid@maxoid:~> su -
maxoid:~ # dolphin
“/usr/bin/dolphin(11661)” Error in thread 3056801488 : “org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.NepomukServer was not provided by any .service files”
“/usr/bin/dolphin(11661)” Error in thread 3056801488 : “org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.NepomukServer was not provided by any .service files”
maxoid:~ # QDBusConnection received a message of type 3 that it shouldn’t have
error: “org.freedesktop.DBus.Error.ServiceUnknown” “The name org.kde.kded was not provided by any .service files”
kbuildsycoca4 running…

Errors are the same as from “kdesu dolphine”, but it’s work.
What the problem?

The problem is disappear after I first start dolphin from console as a root!

Try deleting linkonq5
it worked for me and some others

Where is this file? I can’t find.

I assumed you had the repo:
Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0

it’s in there

not sure if it’s in the default suse repo’s. If that’s all you have, then you probably don’t have it but…

in terminal type:
rpm -q libkonq4 libkonq5

post results

The result is
>rpm -q libkonq4 libkonq5
package libkonq5 is not installed

The file list for this RPM:

then add
Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0

also the extras and community repo’s fom the same section
run updates on the repo’s

but, if you don’t have the libkonq5 anyway, I would file a bug report.

I install the latest avalable versions from STABLE repository:

libkonq4 - KDE Konqueror Libraries
Installed Version 4.0.4-22.6
Build Time: Tue 15 Jul 2008 08:51:53 PM SAMST

kde4-dolphin - KDE File Manager
Installed Version 4.0.4-22.6
Build Time: Tue 15 Jul 2008 08:51:53 PM SAMST

But no result.
Resume: to start “dolphin” in super user mode I must start it ones from console with a root privileges. After that it can start from GUI too. After reboot, procedure must be repeated.

Strange I can run them both using kdesu at the same time.
K Desktop Environment
Version 4.00.83 (KDE 4.0.83 (KDE 4.1 Beta2) “release 4.1”

Sorry, I probably wasn’t clear…

I haven’t tried to run both concurrently, but only one at a time.

As noted in this thread, when you launch
kdesu dolphin
you don’t always get a functional Dolphin, the details pane can be blank. When that happens, I’ve instead launched Konqueror (Super User Mode).

On the other hand, I’ve also found that if I can successfully launch Dolphin in super user mode, Konqueror in Super User Mode doesn’t function properly (I’ve forgotten the exact problem since I ran into it, for weeks now I’ve just avoided the problem)

So, I suspect there is a persistent setting somewhere which allows only one app to function properly in super user mode and until/unless that setting is flipped I stick to the one app.

I might also suggest that you try doing more than simply launching both apps at the same time, you should also test functionality (access and do file operations which require root permissions)

What I found is entirely circumstantial and “just works” for me, I didn’t try to dig deeper into <why> what I described happens.

hii all

I had the same problem as stated above…deleting libkonq5 did work…my dolphin is jumping out of the water again…am using a 64 bit opensuse11 on a dula core machine