Kdenlive5 with TW

Okay, just got back to it and I’m glad I checked this thread, I was going thru logs with no luck. So yes, updated and all is working as expected, I’ve even created a quick and dirty AVC 10bit render test, so far so good. I’ll try some plugins next.

FYI, FFMpeg has 10bit transcode support for a while now with libx264, libx265, etc. This is independent of just the ability to handle decode of 10bit sources, IIRC. But, for usage as the encoder, yes, you have to have two builds right now, one for 8bit, one for 10bit output, presumably because of libx264(libx265). The config is just --bit-depth=10.

Yeah well, scratch that…it’s not using my ffmpeg for some reason…

Hm, have you explicitely set your executable in kdenlive5’s settings?
Maybe try to copy it to /usr/local/bin/ or even /usr/bin/ instead of the original one? (as a test at least)

I have to admit that I have absolutely no idea about the inner workings of mlt.
But I haven’t changed anything that could cause this when building it, I just branched it from KDE:Application which in turn is the same as Packman’s package, except that it’s been updated to the latest version and builds against Qt5.
So if it worked before, this must either be a configuration issue, or a change in mlt between 0.9.2 and 0.9.6 I’d say.

Btw, I found that mailinglist thread about the problems with 10bit support in x264/libx264:

Well, I just did a quick test by replacing /usr/bin/ffmpeg with a script that just writes it parameters into a log file, and then rendering a small project with both kdenlive4 and kdenlive5.
In both cases the log file did not get created, and the video was still correctly rendered.
So it seems that melt (even the older version 0.9.2) just doesn’t use ffmpeg (the executable) at all, sorry.

Kdenlive does use the ffmpeg executable specified in its settings for transcoding (“Transcode clips” in the “File” menu, or when creating a DVD) though. But I suppose that won’t help you much…

Well, I’m at a loss and you’re right, even specifying -vcodec in the profile, it’s clearly not using my FFMpeg_10 for rendering. I’m sitting here with numerous 10bit encodes from my AVCHD sources and I can’t replicate/remember the workflow as to how I got them with kdenlive…(perhaps I didn’t)

Back to square one, I guess. Hate this. I’m going to try removing ffmpeg/et al and building/installing the libs myself, 10bit.

So, I had time to sit down with it…found out I was taking my renders from kdenlive and then transcoding to 10bit with an external script. Not optimal, generally bad.

The better solution is to rebuild x264/ffmpeg as 10-bit output and then build mlt/kdenlive (Using new QT5-based sources) against that and you’re good to go, no superfluous second step. To maintain the distro ffmpeg libs, you can build in another location and use the kdenlive “Generate script” option. You can then modify the scripts to set the LD_LIBRARY_PATH for the call to kdenlive_render/melt and off you go.

Not for novice users: Building with external ffmpeg

I guess technically this is a bit OT, but could be useful for those looking to go 10bit.