kdenlive, repeated SIGSEGV


kdenlive is repeatingly crashing with the following debug info:

Application: Kdenlive (kdenlive), signal SIGSEGV
0x00007f888a2517b5 in pthread_join () from /lib64/libpthread.so.0
[Current thread is 1 (Thread 0x7f888b36f750 (LWP 12443))]

Thread 2 (Thread 0x7f8870c94950 (LWP 12495)):
[KCrash Handler]
#5 0x00007f886a6fd370 in ?? ()
#6 0x00007f888a24fc49 in __nptl_deallocate_tsd () from /lib64/libpthread.so.0
#7 0x00007f888a25107e in start_thread () from /lib64/libpthread.so.0
#8 0x00007f8883fef10d in clone () from /lib64/libc.so.6
#9 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f888b36f750 (LWP 12443)):
#0 0x00007f888a2517b5 in pthread_join () from /lib64/libpthread.so.0
#1 0x00007f88783ba742 in ?? () from /usr/lib64/mlt/libmltsdl.so
#2 0x00007f888af8b8b2 in mlt_consumer_stop () from /usr/lib64/libmlt.so.1
#3 0x0000000000472255 in _start ()

this happens under Gnome, KDE and wmii2 with the same libs and functions. as far as i can tell, this happens when kdenlive is buffering/reading video files.

anybody can confirm this?

I’m not very good at solving these sorts of things … but you could start by providing the output of:

rpm --query --all '*mlt*' '*kdenli*' | sort

On my 64-bit openSUSE-11.1 PC running KDE-3.5.10 I get:

oldcpu@hal1000:~> rpm --query --all '*mlt*' '*kdenli*' | sort

… also advise what version of openSUSE you are using?

Note you need “mlt” which will likely be missed in the required kde4-kdenlive dependencies.

linux-5jrm:/root :~> rpm --query --all ‘mlt’ ‘kdenli’ | sort

its opensuse 11.1, tested kde 4.1 and gnome 2.6x + wmii2

Note you need “mlt” which will likely be missed in the required kde4-kdenlive dependencies.

do you think it would be worth to try reinstalling kdenlive with the package mlt-devel?

anyway, thanks for your help :slight_smile:

If it was me, I would remove kde4-kdenlive and ALL of the mlt apps, and also rename /home/yourusername/.kde4/share/apps/kdelnive to /home/yourusername/.kde4/share/apps/kdelnive-bak and then re-install the removed apps.

… and try again.

well now i get SIGILL’s:

Application: Kdenlive (kdenlive), signal SIGILL
0x00007feda805f7b5 in pthread_join () from /lib64/libpthread.so.0
[Current thread is 1 (Thread 0x7feda917d750 (LWP 6434))]

Thread 2 (Thread 0x7fed8ef99950 (LWP 6461)):
[KCrash Handler]
#5 0x00007fed8729c370 in ?? ()
#6 0x00007feda805dc49 in __nptl_deallocate_tsd () from /lib64/libpthread.so.0
#7 0x00007feda805f07e in start_thread () from /lib64/libpthread.so.0
#8 0x00007feda1dfd10d in clone () from /lib64/libc.so.6
#9 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7feda917d750 (LWP 6434)):
#0 0x00007feda805f7b5 in pthread_join () from /lib64/libpthread.so.0
#1 0x00007fed961c8742 in ?? () from /usr/lib64/mlt/libmltsdl.so
#2 0x00007feda8d998b2 in mlt_consumer_stop () from /usr/lib64/libmlt.so.1
#3 0x00007fed961c90da in ?? () from /usr/lib64/mlt/libmltsdl.so
#4 0x00007feda8b720a8 in Mlt::Consumer::~Consumer() () from /usr/lib64/libmlt++.so.2
#5 0x00000000004709b3 in _start ()

How basic is your openSUSE? Have you added a bunch of 3rd party repos?

not that i know

root@linux:~> zypper lr

| Alias | Name | Enabled | Refresh

1 | KDE:42 | KDE:42 | Yes | Yes
2 | NVIDIA Repository | NVIDIA Repository | Yes | Yes
3 | Packman Repository | Packman Repository | Yes | Yes
4 | home:allau | home:allau | Yes | Yes
5 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
6 | openSuse_Mozilla | openSuse Mozilla | Yes | Yes
7 | opensuse_compiz | opensuse compiz | Yes | Yes
8 | opensuse_nvidia | opensuse nvidia | Yes | Yes
9 | opensuse_windowmanager | opensuse windowmanager | Yes | Yes
10 | opensuse_wine | opensuse wine | Yes | Yes
11 | repo-debug | openSUSE-11.1-Debug | No | Yes
12 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
13 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
14 | repo-source | openSUSE-11.1-Source | No | Yes
15 | repo-update | openSUSE-11.1-Update | Yes | Yes

the mlt and kdenlive packages are from packman

Wow! Many repos. I recommend you disable all those in RED.

Then remove kdenlive and remove mlt. Also rename the /home/yourusername/.kde4/share/apps/kdelnive directory again. And then try again to install kdenlive.

But it may be too late now. You may have irretreivably installed from one of those repos, an underlying app that kdelinve depends upon, and that underlying app may not have been given the proper testing that a Novell/SuSE-GmbH app would have been given. Trying to figure out what app, if any, is VERY difficult. It requires a level of knowledge that not many of us have.

I always recommend users ONLY setup OSS, Non-OSS, Update and Packman repos and NO OTHERS!! None ! Just those 4. Others can be added on an adhoc basis for the install of a specific package and then removed immediately afterward. IMHO one should also ONLY install and keep others if one knows how to detect the problems introduced by having others, and how to solve the problems.

Anyway, … my view is your PC having those extra repos has caused harm that may not be fixable with out spending excessive time.

I was going to ask for your codecs via:

rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' '*layer*' '*vlc*' | grep -v avahi | sort

but IMHO there is no point. My view is this is a problem self induced by adding and then leaving in place inappropriate repositories. And it could be very hard to fix.

Thats the same kind of error I get. I’ll keep track of this just in case you solve it.