Kdenlive - Problem with audio in rendered avi/mp4 videos

Just started recently. I’m using Suse 11.4/x86 with all the latest packages from the suse/packman repos. After the video is created, the audio is echoey and scratchy. The problem does not occur with mpeg2 or dv video rendering. The problem is only with mpeg4 / avi creation. I also have a problem with no audio in “SOME” thumbnails. Seems to be the same mp3/mp4 issue. Anyone have any ideas?

Thanks.

You know that we are up to openSUSE 12.2 with 12.3 to come in March, right? So you are using an older version of openSUSE. You say that your multimedia is up to snuff. Can you check it out with this?

https://forums.opensuse.org/blogs/jdmcdaniel3/mmcheck-version-2-35-check-your-multimedia-16-steps-bash-script-file-36/

Let us know what you find out after running mmcheck. I wrote this before 11.4, but mmcheck is updated to work with 12.2, so some newer package versions may not exist for 11.4 now.

Thank You,

I know about 12.2/12.3. But my system is loaded with extra packages, and works great aside from the Kdenlive issue. I installed mmcheck, it does work.

I ran mmcheck, all is fine. I ran several different #'s. What does kdenlive use for processing the audio portion to mp3/aac?

and the results?

The problem is only with mpeg4 / avi creation.

what audio codec are you using wen you encode to .mp4 or .avi?
Have you tried specifying a different audio codec?

What are you using to playback your files? Have you ruled out the problem with audio being in the player and not the encoded file?

edit: Oh, I see you have created a new post while I was writing mine.

I don’t use kdenlive but I believe it uses ffmpeg for audio processing.

A recent ffmpeg update broke melt (mlt) in kdenlive and also broke some other apps. There are a number of posts in the Packman mailing list about this The Packman January 2013 Archive by thread .

The latest post is here: [packman] mlt/melt/kdenlive]([packman] mlt/melt/kdenlive) where the Packman packager notes:

I’ll try to find a solution this weekend, otherwise i’ll downgrade to ffmpeg 1.0.1

So possibly early next week there will be a fix, which may mean a downgrade to ffmpeg 1.0.1.

OK, That explains it. I noticed the problem happened after I updated my system. I’ll try downgrading ffmpeg.

Thanks!

which I compiled from source, does not solve the problem. FFmpeg is not the problem. What else would cause rendered videos to have bad audio? and no audio in certain thumbnails. Like I said, the problem only started about a week ago. How do I get a list of all the packages I recently updated?

Thanks

Its possible that mlt/melt needs to be rebuilt with the downgraded ffmpeg.

Have you posted this on the Kdenlive forums? You might find something there. I was having a problem with Kdenlive so I used the “build script”. That compiles it’s own ffmpeg “locally”, and a few other packages, so updates to ffmpeg on your system supposedly won’t break the “local” ffmpeg.

Where can I get the source code for mlt and melt for 11.4. I’ll compile those first, then compile ffmpeg.

I am having a problem when I enter the cmake command. It does not work. I followed the instructions exactly. I created a “build” directory, then did the cmake command. I tried it in every directory. I have everything installed including cmake. I enter cmake, then it wants options for usage. I already compiled mlt from source.

so if changed to the source folder and did …

mkdir build
cd build
cmake ..
make
sudo make install

Does that work?

When I entered “cmake …”, I did not leave a space before the “…” . Kdenlive is compiled and works. I have a new problem. When I compile mlt from source I get this:

Configuring framework:
Configuring modules:
Configuring modules/avformat:

  • libavformat not found: disabling
    Configuring modules/core:
    Configuring modules/decklink:
    Configuring modules/dv:
    Configuring modules/feeds:
    Configuring modules/frei0r:
    Configuring modules/gtk2:
    Libexif found, enabling auto rotate
    Configuring modules/jackrack:
    Configuring modules/kdenlive:
    Configuring modules/lumas:
    Configuring modules/oldfilm:
    Configuring modules/plus:
    Configuring modules/rtaudio:
    Configuring modules/sdl:
    Configuring modules/sox:
    Configuring modules/swfdec:
    Configuring modules/vmfx:
    Configuring modules/vorbis:
    Configuring modules/xml:
    Configuring melt:
    Configuring mlt++:
    Configuring swig:
    LGPLv2.1 license used; GPL components disabled

Why is libavformat not found? I have ffmpeg installed, and using the locate command I find it. How do I correct this?

Thanks.

OK, If I put back the 1.0.1 version of ffmpeg I compiled from source, then libavformat is found. At this point Kdenlive is installed OK, and ffmpeg is installed OK. Now when I issue a “make” command for mlt, I get this error. Never ends. I need mlt! LOL.

/home/doug/ffmpeg-1.0.1/libavdevice/v4l2.c:477: undefined reference to clock_gettime' collect2: ld returned 1 exit status make[2]: *** ../libmltavformat.so] Error 1 make[2]: Leaving directory /home/doug/mlt-0.8.6/src/modules/avformat’
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/doug/mlt-0.8.6/src/modules’
make: *** [all] Error 1
doug@linux-rvej:~/mlt-0.8.6>

The build script builds a “local” version of “melt”, and in the “Share” directory, I see an “mlt” directory. I think compiling mlt separately isn’t needed. My build has a directory named “20121226”, the date it was built. In there is a script named “start-kdenlive”. That’s what I run to get Kdenlive. Did you try that? It’s supposed to use all “local” packages built by the build script, if I understand things correctly. Then if you get an online update of any packages, it’s not supposed to affect Kdenlive. You probably also have kdenlive in /usr/local/bin or some such location, so running that one won’t run the version compiled by the build script. At least that’s my understanding…

On Sun 20 Jan 2013 12:26:01 AM CST, Doug08 wrote:

OK, If I put back the 1.0.1 version of ffmpeg I compiled from source,
then libavformat is found. At this point Kdenlive is installed OK, and
ffmpeg is installed OK. Now when I issue a “make” command for mlt, I get
this error. Never ends. I need mlt! LOL.

/home/doug/ffmpeg-1.0.1/libavdevice/v4l2.c:477: undefined reference to
clock_gettime' collect2: ld returned 1 exit status make[2]: *** ../libmltavformat.so] Error 1 make[2]: Leaving directory /home/doug/mlt-0.8.6/src/modules/avformat’
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/doug/mlt-0.8.6/src/modules’
make: *** [all] Error 1

Hi
Undefined reference usually means the linker flag is missing… in that
case -lrt you need to look into the makefile of make by adding the
LDFLAG=“$LDFLAG -lrt”


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 3 days 3:34, 4 users, load average: 0.06, 0.14, 0.10
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

OK, I had to re-compile ffmpeg with all the --enable flags that the kdenlive website says to do. I was able to compile mlt after that. So now I have mlt working, ffmpeg working, and kdenlive working. The audio thumbnails now have sound…BUT, I cannot render any videos. This sucks. When I click render, it goes to 100% right away. It does not matter what type of video I choose. Now what? Never ending.

Thanks.

ffmpeg has been rolled back by Packman packagers and mlt/melt and kdenlive updated to work with that version. Has anyone tried kdenlive now with this update in place ?