Kdenlive opens any video clip only as audio (other apps can play videos just fine)

Hello, I recently installed Kdenlive on my Opensuse Linux desktop computer. I used it before, in past installation, without issues, but this time I get a strange behavior: any video clip that plays just fine with a number of other video applications is shown within Kdenlive only as an audio.
I suspect it is a codecs issue, but I have all the codecs that allow those videos to play in all other video players (Kaffeine, VLC, etc).
I attach a screenshot of how a mpeg clip appears when imported into Kdenlive.
I installed Kdenlive from Yast, and I have version 20.04.2.
I posted on Kdenlive forum but they told me that it is not something they can help with because I installed it from the Opensuse repositories and not from Flatpak.
I was wondering if the current installation is salvageable, or uninstalling and re-installing from Flatpak would be the only way. There are a bunch of modifications to large libraries that Flatpak tries to do if I choose to install their version, so I would like to avoid that route if at all possible.
Thank you so much in advance for any suggestion!!!

For solving this you really need to upgrade / install a recent version, i.e. 15.5 or 15.6 ( released 2024-06-12 ), first.

I also need to update my LEAP versions, with my having only 15.3 on my laptop and 15.4 on my desktop. Having typed that, I use kdenlive on both and they work fine. That suggests to me something is misconfigured in your LEAP-15.3 EOL.

My laptop 15.3 also has kdenlive 20.04.2. When you go to "Settings’ and select “Run Config Wizard” do you get “Codecs have been updated, everything seems fine” ?

As recommended already on this thread, we BOTH need to update our LEAP versions, but having typed that, given kdenlive-20.04.2 works fine on my LEAP-15.3 (on my laptop), I suspect your issue could be more systemic in terms of either a missing a Codec, or having a faulty kdenlive install.

As an aside, I also want to try out more flatpak versions, but I am finding (the way my LEAP setup) that flatpak consumes large amount of / (root) as opposed to consuming space in /home, and to accommodate such I can’t do a simple upgrade to a newer LEAP, but I will need to do a major change in the partitioning of my laptop’s hard drive (to massive increase " / " ) .

This is all very doable, (as part of an update to a newer LEAP version) but it takes care and takes time to do and I have been somewhat busy as of late (and I have also been a bit ill).

Having typed that - I do not believe you need to use flatpak to get kdenlive to work - but if you do go that route, let us know how it works.

If there is anything I can check on 15.3 (with the same kdenlive version as you) let me know. I am still ‘on the mend’ and it may be a week or so before I repartition my laptop and upgrade my LEAP-15.3 - so there are a couple of weeks in which I can possibly help you.

@oldcpu You should be installing flatpaks as your user, sounds like it’s been added as system…

I use;

# Add flathub repository as user
flatpak --user remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

# Install flatpak applications
flatpak --user install --noninteractive com.github.tchx84.Flatseal

Thank you for the responses!!
I have Leap 15.5 on my laptop and with this little desktop computer I got lazy. I will install Tumbleweed in the near future.
Kdenlive works fine everywhere else (including many past, much older versions).
From within the settings, it tells me the codecs are fine.
I went all the way through adding flatpak repository as a user and trying to install the flatpak applications but I aborted that because it was trying to change so many packages, and I opted not to do that, given that this is an outdated system.
Screenshot_20240611_090749