Kdenlive not rendering DVD

Having upgraded to from 11.3 to 11.4 I now am unable to render in KDENLIVE. I’ve installed MLT, FFMPEG and KDELIVE with dependencies from Packman.

What is different from my 11.3 install is MLT has moved up a notch. 0.5.10 to 0.6.2. Does 0.6.2 work with KDENLIVE 0.7.8? I would think it should.

I have see MLT 0.7.0 is released but will wait for the RPM to be released on Packman.

This is the message taken from terminal.

//STARTING RENDERING: true , false , “/usr/bin/melt” , “dv_pal” , “avformat” , “-” , “/tmp/kde-allianux/kdenliveTR5078.mlt” , “/home/allianux/kdenlive/test-1.vob” , () , (“f=dvd”, “vcodec=mpeg2video”, “acodec=ac3”, “b=5000k”, “maxrate=8000k”, “minrate=0”, “bufsize=1835008”, “mux_packet_s=2048”, “mux_rate=10080000”, “ab=192k”, “ar=48000”, “s=720x576”, “g=15”, “me_range=63”, “trellis=1”, “profile=dv_pal”, “pass=1”) , -1 , -1
Started render process: “/usr/bin/melt” “/tmp/kde-allianux/kdenliveTR5078.mlt -profile dv_pal -consumer avformat:/home/allianux/kdenlive/test-1.vob progress=1 f=dvd vcodec=mpeg2video acodec=ac3 b=5000k maxrate=8000k minrate=0 bufsize=1835008 mux_packet_s=2048 mux_rate=10080000 ab=192k ar=48000 s=720x576 g=15 me_range=63 trellis=1 profile=dv_pal pass=1”
Rendering of “/home/allianux/kdenlive/test-1.vob” aborted, resulting video will probably be corrupted.

My captured video is in AVI 2 format, standard def.

Does anyone else have this problem?

Don’t use it at the moment.
You could check in at #packman on IRC

In the mean time try devede or mandvd

Yes, I have exactly the same problem. DeVeDe and ManDVD make a DVD but sound is corrupt if encoded with AC3 or there’s no sound at all (on a DVD player) without AC3.

Kdenlive is still broken, I wonder if libAV (FFMPEG) is the culprit? I assume this is a Packman build issue as it worked well in Opensuse 11.3 before Packman did their reshuffle? I did not find the answer on #packman IRC :\

You could add tumblweed packman, disable the main packman

Delete libav and install ffmpeg, you have to roll back a few packages to get it
I did it because libav broke get_iplayer, which uses ffmpeg
Now get_iplayer works

I locked all my packman stuff and made a copy of the tumbleweed repo to my local machine :smiley:

Thanks for the tip, unfortunately the packman tumbleweed FFMPEG did not fix the Kdelive issue… however it did fix a few other issues as mentioned get_iplayer works again.

I think it much more helpful if those on this thread with a problem are more accurate their statements, as I find this statement misleading (and most the other posts misleading). I can not reproduce the noted problems.

I just finished rendering a video in 4 different output formats with KDEnlive (at 1280x720 resolution) : h264, xvid4, mpeg2 and mpeg4 output codes. Yes, 1280x720 is NOT DVD resolution, but its misleading to kdenlive fans if one does not continue to note that it is either a specific output video (or audio) input or output codec that is causing some problems (at least I assume that to be the case - BECAUSE I can NOT reproduce the problem). This ‘just works’ for me on a 64-bit openSUSE-11.4 KDE4 install (with the nominal stock KDE4 that comes with 11.4). ie Audio and video of the rendered video play back fine! (note I input an mp3 as my audio track as I do not keep my audio tracks in ac3 - once kdenlive has the audio track it converts it to the appropriate audio output format - for input I do NOT have any ac3 tracks (why would one keep a separate audio track in ac3 format ? ).

I then changed my settings to DVD PAL and outputed same video to output DVD format (in mpeg2). It also ‘just works’. Audio and video playback fine. According to ‘tovid id’ this output is DVD compliant and would work if I were to burn it to a dvd.

So I can’t reproduce the problem noted here-in this thread - but if I was to blindly read the thread and not do any testing I would be left thinking KDEnlive does not work at all in 11.4, and yet the contrary is the case. KDEnlive works for me and I can’t reproduce the failure with the information provided.

My application versions:

Looking back now this was a bit grumpy … and apologies for that.

I understand some are frustrated here by problems - and I do believe they have legitimate problems and I am sorry to read of that.

I guess I need to qualify this better - that some of us rely on the accurate posts/assessments of others before we switch our main PCs to 11.4. And if I had not installed a test partition on my main PC and tested, I would have been totally scared away by the posts in this thread - when in fact KDEnlive is working well on my test partition of 11.4.

I do not have this ac3 problem with kdenlive.

I took an mp3 file, and I converted it to the ac3 format with microchip’s audenc (44100 Hz stero, and bitrate of 192.0 kbps). I dragged it into kdenlive (version number per my above post). I rendered to DV/dVD PAL mpeg-2 8000K. Audio (and video) of the rendered kdenlive file played fine in smplayer. Nice !

So I tried - but I can not reproduce your problem. I am sorry to read you have this, but I have done nothing special other than limit my 64-bit openSUSE-11.4 (KDE) repositories to the nominal oss, non-oss, update and packman repositories.

Yes, I should have provided a little more detail. The problem is with rendering into .VOB (aspect 4:3 with 2-pass) format in Kdenlive 0.78. The rendering process simply does not start.
When creating a DivX movie to play on a set top box (Panasonic) a small window effect is created and it is not full screen as it should be. I am confidant the problem is with FFMEG or a related lib but do not know how to show it other than my first terminal output in the first post.
Kdenlive 0.7.8 works well with MLT 0.6.2 and there seem to be other multimedia apps affected which would suggest it to be a problem with a shared lib.
Hope this explanation adds to the needed info to the first post?

I tried 5 or more DVD making programs and not a single one could make a DVD with sound playable on a DVD player. Video is OK, but sound is just cracking noise if re-encoded with AC3 or dead silence if audio is left as is from the original file.

Have you actually tried burning the DVD and playing it in a normal DVD player? I can play non-AC3-re-encoded DVDs on my computer just fine with sound, but not on the DVD player.

From what I read, if one is encoding for a DVD, ac3 is pretty much the best choice, IF it works. According to this URL Which audio format to use for DVD movies - AC3, PCM or MP2 ? there are 3 audio formats that are typically used: AC3, PCM, and MP2.

PCM (.wav or .aiff) is not recommended because it stores audio without compression (and hence audio could be larger than video, restricting what one can put on a DVD). The recommendation is to not use PCM in final versions of DVD.

MP2 format is not officially supported for NTSC video and it is not supported by all DVD devices.

Ergo AC3 is the main choice for burning a DVD, and most (all ? ) Linux DVD burning programs will convert a video file’s audio to AC3 in preparation for burning.

That makes any AC3 bug particularly nasty wrt home made DVDs.

Just to let you know that Packman has updated MLT to version 0.7.0 and a package revision to Kdenlive 0.7.8 (assumed to be compiled against the new MLT package). The good news is that it is rendering correctly again (Tested .vob and xvid4). Thank you Pascal :slight_smile:

I DO have Kdenlive-0.7.8 and it does NOT work! I mean it doesn’t encode AC3. Nothing does at the moment.

But have you tried the new packages from Packman released yesterday? You are correct the Kdenlive-0.7.8 is not new as we are all waiting for 0.8 to be released. But the package manager has provided a new package that works.
Kdenlive 0.7.8-1.pm.1.2 (note the “2” at the end)
MLT 0.7.0-1.pm.2.1

Just updated to *-1.2 and it crashes without even starting:

:~> kdenlive
*** glibc detected *** kdenlive: malloc(): memory corruption: 0x0000000000e285c0 ***
======= Backtrace: =========
======= Memory map: ========
00400000-006ef000 r-xp 00000000 08:02 146772                             /usr/bin/kdenlive
008ee000-008ef000 r--p 002ee000 08:02 146772                             /usr/bin/kdenlive
008ef000-008f4000 rw-p 002ef000 08:02 146772                             /usr/bin/kdenlive
008f4000-00f01000 rw-p 00000000 00:00 0                                  [heap]
7ffd58000000-7ffd58021000 rw-p 00000000 00:00 0 
7ffd58021000-7ffd5c000000 ---p 00000000 00:00 0 
7ffd5f8f0000-7ffd5f936000 r--p 00000000 08:02 536980                     /usr/share/fonts/truetype/arialbd.ttf
7ffd5f936000-7ffd5f97a000 r--p 00000000 08:02 536982                     /usr/share/fonts/truetype/arial.ttf
7ffd5f97a000-7ffd5fae5000 r-xp 00000000 08:02 138469                     /usr/lib64/libsamplerate.so.0.1.7
7ffd5fae5000-7ffd5fce4000 ---p 0016b000 08:02 138469                     /usr/lib64/libsamplerate.so.0.1.7
7ffd5fce4000-7ffd5fce5000 r--p 0016a000 08:02 138469                     /usr/lib64/libsamplerate.so.0.1.7
7ffd5fce5000-7ffd5fce6000 rw-p 0016b000 08:02 138469                     /usr/lib64/libsamplerate.so.0.1.7
7ffd5fce6000-7ffd5fce8000 r-xp 00000000 08:02 269936                     /usr/lib64/mlt/libmltresample.so
7ffd5fce8000-7ffd5fee7000 ---p 00002000 08:02 269936                     /usr/lib64/mlt/libmltresample.so
7ffd5fee7000-7ffd5fee8000 r--p 00001000 08:02 269936                     /usr/lib64/mlt/libmltresample.so
7ffd5fee8000-7ffd5fee9000 rw-p 00002000 08:02 269936                     /usr/lib64/mlt/libmltresample.so
7ffd5fee9000-7ffd5fef3000 r-xp 00000000 08:02 269942                     /usr/lib64/mlt/libmltxml.so
7ffd5fef3000-7ffd600f2000 ---p 0000a000 08:02 269942                     /usr/lib64/mlt/libmltxml.so
7ffd600f2000-7ffd600f3000 r--p 00009000 08:02 269942                     /usr/lib64/mlt/libmltxml.so
7ffd600f3000-7ffd600f4000 rw-p 0000a000 08:02 269942                     /usr/lib64/mlt/libmltxml.so
7ffd600f4000-7ffd6011c000 r-xp 00000000 08:02 138430                     /usr/lib64/libwavpack.so.1.1.4
7ffd6011c000-7ffd6031b000 ---p 00028000 08:02 138430                     /usr/lib64/libwavpack.so.1.1.4
7ffd6031b000-7ffd6031c000 r--p 00027000 08:02 138430                     /usr/lib64/libwavpack.so.1.1.4
7ffd6031c000-7ffd6031d000 rw-p 00028000 08:02 138430                     /usr/lib64/libwavpack.so.1.1.4
7ffd6031d000-7ffd60320000 r-xp 00000000 08:02 143739                     /usr/lib64/libpulse-simple.so.0.0.3
7ffd60320000-7ffd6051f000 ---p 00003000 08:02 143739                     /usr/lib64/libpulse-simple.so.0.0.3
7ffd6051f000-7ffd60520000 r--p 00002000 08:02 143739                     /usr/lib64/libpulse-simple.so.0.0.3
7ffd60520000-7ffd60521000 rw-p 00003000 08:02 143739                     /usr/lib64/libpulse-simple.so.0.0.3
7ffd60521000-7ffd60537000 r-xp 00000000 08:02 145859                     /usr/lib64/libid3tag.so.0.3.0
7ffd60537000-7ffd60737000 ---p 00016000 08:02 145859                     /usr/lib64/libid3tag.so.0.3.0
7ffd60737000-7ffd60739000 r--p 00016000 08:02 145859                     /usr/lib64/libid3tag.so.0.3.0
7ffd60739000-7ffd6073a000 rw-p 00018000 08:02 145859                     /usr/lib64/libid3tag.so.0.3.0
7ffd6073a000-7ffd60759000 r-xp 00000000 08:02 146782                     /usr/lib64/libmad.so.0.2.1
7ffd60759000-7ffd60958000 ---p 0001f000 08:02 146782                     /usr/lib64/libmad.so.0.2.1
7ffd60958000-7ffd60959000 r--p 0001e000 08:02 146782                     /usr/lib64/libmad.so.0.2.1
7ffd60959000-7ffd6095a000 rw-p 0001f000 08:02 146782                     /usr/lib64/libmad.so.0.2.1
7ffd6095a000-7ffd60962000 r-xp 00000000 08:02 144272                     /usr/lib64/libao.so.4.0.0
7ffd60962000-7ffd60b61000 ---p 00008000 08:02 144272                     /usr/lib64/libao.so.4.0.0
7ffd60b61000-7ffd60b62000 r--p 00007000 08:02 144272                     /usr/lib64/libao.so.4.0.0
7ffd60b62000-7ffd60b63000 rw-p 00008000 08:02 144272                     /usr/lib64/libao.so.4.0.0
7ffd60b63000-7ffd60b70000 r-xp 00000000 08:02 138722                     /usr/lib64/libgomp.so.1.0.0
7ffd60b70000-7ffd60d6f000 ---p 0000d000 08:02 138722                     /usr/lib64/libgomp.so.1.0.0
7ffd60d6f000-7ffd60d70000 r--p 0000c000 08:02 138722                     /usr/lib64/libgomp.so.1.0.0
7ffd60d70000-7ffd60d71000 rw-p 0000d000 08:02 138722                     /usr/lib64/libgomp.so.1.0.0
7ffd60d71000-7ffd60d8a000 r-xp 00000000 08:02 134265                     /usr/lib64/libmagic.so.1.0.0
7ffd60d8a000-7ffd60f89000 ---p 00019000 08:02 134265                     /usr/lib64/libmagic.so.1.0.0
7ffd60f89000-7ffd60f8a000 r--p 00018000 08:02 134265                     /usr/lib64/libmagic.so.1.0.0
7ffd60f8a000-7ffd60f8b000 rw-p 00019000 08:02 134265                     /usr/lib64/libmagic.so.1.0.0
7ffd60f8b000-7ffd60f8d000 rw-p 00000000 00:00 0 
7ffd60f8d000-7ffd60f96000 r-xp 00000000 08:02 138648                     /usr/lib64/libltdl.so.7.2.1
7ffd60f96000-7ffd61195000 ---p 00009000 08:02 138648                     /usr/lib64/libltdl.so.7.2.1
7ffd61195000-7ffd61196000 r--p 00008000 08:02 138648                     /usr/lib64/libltdl.so.7.2.1
7ffd61196000-7ffd61197000 rw-p 00009000 08:02 138648                     /usr/lib64/libltdl.so.7.2.1
7ffd61197000-7ffd6123c000 r-xp 00000000 08:02 146959                     /usr/lib64/libsox.so.1.0.0
7ffd6123c000-7ffd6143b000 ---p 000a5000 08:02 146959                     /usr/lib64/libsox.so.1.0.0
7ffd6143b000-7ffd6143f000 r--p 000a4000 08:02 146959                     /usr/lib64/libsox.so.1.0.0
7ffd6143f000-7ffd61444000 rw-p 000a8000 08:02 146959                     /usr/lib64/libsox.so.1.0.0
7ffd61444000-7ffd61445000 rw-p 00000000 00:00 0 
7ffd61445000-7ffd61447000 r-xp 00000000 08:02 269938                     /usr/lib64/mlt/libmltsox.so
7ffd61447000-7ffd61647000 ---p 00002000 08:02 269938                     /usr/lib64/mlt/libmltsox.so
7ffd61647000-7ffd61648000 r--p 00002000 08:02 269938                     /usr/lib64/mlt/libmltsox.so
7ffd61648000-7ffd61649000 rw-p 00003000 08:02 269938                     /usr/lib64/mlt/libmltsox.so
7ffd61649000-7ffd6164d000 r-xp 00000000 08:02 269928                     /usr/lib64/mlt/libmltkdenlive.so
7ffd6164d000-7ffd6184c000 ---p 00004000 08:02 269928                     /usr/lib64/mlt/libmltkdenlive.so
7ffd6184c000-7ffd6184d000 r--p 00003000 08:02 269928                     /usr/lib64/mlt/libmltkdenlive.so
7ffd6184d000-7ffd6184e000 rw-p 00004000 08:02 269928                     /usr/lib64/mlt/libmltkdenlive.so
7ffd6184e000-7ffd61853000 r-xp 00000000 08:02 269925                     /usr/lib64/mlt/libmltfrei0r.so
7ffd61853000-7ffd61a52000 ---p 00005000 08:02 269925                     /usr/lib64/mlt/libmltfrei0r.so
7ffd61a52000-7ffd61a53000 r--p 00004000 08:02 269925                     /usr/lib64/mlt/libmltfrei0r.so
7ffd61a53000-7ffd61a54000 rw-p 00005000 08:02 269925                     /usr/lib64/mlt/libmltfrei0r.so
7ffd61a54000-7ffd61a57000 r-xp 00000000 08:02 269932                     /usr/lib64/mlt/libmltnormalize.so
7ffd61a57000-7ffd61c56000 ---p 00003000 08:02 269932                     /usr/lib64/mlt/libmltnormalize.so
7ffd61c56000-7ffd61c57000 r--p 00002000 08:02 269932                     /usr/lib64/mlt/libmltnormalize.so
7ffd61c57000-7ffd61c58000 rw-p 00003000 08:02 269932                     /usr/lib64/mlt/libmltnormalize.so
7ffd61c58000-7ffd61cd8000 r-xp 00000000 08:02 143521                     /usr/lib64/libquicktime.so.0.0.0
7ffd61cd8000-7ffd61ed8000 ---p 00080000 08:02 143521                     /usr/lib64/libquicktime.so.0.0.0
7ffd61ed8000-7ffd61ed9000 r--p 00080000 08:02 143521                     /usr/lib64/libquicktime.so.0.0.0
7ffd61ed9000-7ffd61edc000 rw-p 00081000 08:02 143521                     /usr/lib64/libquicktime.so.0.0.0
7ffd61edc000-7ffd61edd000 rw-p 00000000 00:00 0 
7ffd61edd000-7ffd61ef4000 r-xp 00000000 08:02 269929                     /usr/lib64/mlt/libmltkino.so
7ffd61ef4000-7ffd620f4000 ---p 00017000 08:02 269929                     /usr/lib64/mlt/libmltkino.so
7ffd620f4000-7ffd620f5000 r--p 00017000 08:02 269929                     /usr/lib64/mlt/libmltkino.so
7ffd620f5000-7ffd620f6000 rw-p 00018000 08:02 269929                     /usr/lib64/mlt/libmltkino.so
7ffd620f6000-7ffd620ff000 r-xp 00000000 08:02 269934                     /usr/lib64/mlt/libmltplus.so
7ffd620ff000-7ffd622fe000 ---p 00009000 08:02 269934                     /usr/lib64/mlt/libmltplus.so
7ffd622fe000-7ffd622ff000 r--p 00008000 08:02 269934                     /usr/lib64/mlt/libmltplus.so
7ffd622ff000-7ffd62300000 rw-p 00009000 08:02 269934                     /usr/lib64/mlt/libmltplus.so
7ffd62300000-7ffd6230d000 r-xp 00000000 08:02 134270                     /usr/lib64/libusb-1.0.so.0.0.0
7ffd6230d000-7ffd6250c000 ---p 0000d000 08:02 134270                     /usr/lib64/libusb-1.0.so.0.0.0
7ffd6250c000-7ffd6250d000 r--p 0000c000 08:02 134270                     /usr/lib64/libusb-1.0.so.0.0.0
7ffd6250d000-7ffd6250e000 rw-p 0000d000 08:02 134270                     /usr/lib64/libusb-1.0.so.0.0.0
7ffd6250e000-7ffd6251c000 r-xp 00000000 08:02 138574                     /usr/lib64/libraw1394.so.11.0.1
7ffd6251c000-7ffd6271b000 ---p 0000e000 08:02 138574                     /usr/lib64/libraw1394.so.11.0.1
7ffd6271b000-7ffd6271c000 r--p 0000d000 08:02 138574                     /usr/lib64/libraw1394.so.11.0.1
7ffd6271c000-7ffd6271d000 rw-p 0000e000 08:02 138574                     /usr/lib64/libraw1394.so.11.0.1
7ffd6271d000-7ffd62798000 r-xp 00000000 08:02 138616                     /usr/lib64/liborc-0.4.so.0.11.0KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit

[1]+  Stopped                 kdenlive

I’m not convinced the statement “nothing” does is correct. I understand your frustration, and this problem is annoying, but we need to try to be careful and exact in how we describe the problem, before we make such global statements. Else we simply make the problem more difficult to understand, and hence more difficult to solve.

I think the last thing we want to do is make the problem harder to understand.

For example, have you checked h264enc or xvidenc (not for creating DVDs, but for encoding AC3 as part of an audio track) ?

Also, as I noted previous , I believe I encoded AC3 to non-DVD formats in some cases with openSUSE-11.4. BUT as I noted also, I do not have the time now to look into this in detail (as to why it works in some cases but not in other cases).

I tried encoding AC3 with ffmpeg and it works fine. By nothing I meant out of 5 or so DVD making programs in Linux, more precisely in openSUSE-11.4, NONE made a DVD with working sound. I’ve got no idea what encoders all those programs use.

I read someone has replied to your post on the packman packager mailing list with this explanation :

FFmpeg’s AC3 encoder was changed to expect float (instead of int16). The new encoder is faster on typical hardware (and at least not worse in quality). To get the original behaviour, the programs have to open “ac3_fixed” instead of “ac3”. (And yes, I know I’ve claimed in the past we do not break ABI,)

… IF that is the problem, and IF we assume the Packman packagers decide to remain with the ffmpeg update that breaks a nominal ‘ac3’ call from ffmpeg, then the problem is pushed upstream to all the applications that use this latest version of ffmpeg. In which case the developers of those apps need to be contacted and ask that they provide code to work around this different ffmpeg call.

IF it is that ffmpeg change, its rather ugly in its implication/breakage (at least until its fixed).

What apps did you try thus far? We need to contact the developers of those apps to see if they can do anything (ie come up with a fix and new version, that we can then ask the packman packagers to package).

I see the mlt developer is working on a fix (where mlt is called by kdenlive): www.dennedy.org Git - mltframework.org/mlt.git/commitdiff