kdenlive crashes when loading project with saved audio track

I’m currently on vacation, and noted that the kdenlive version on my laptop (running 64-bit openSUSE-11.3 with KDE-4.4.4) will crash when loading a kdenlive file that has an audio track previously saved.

ie one can no longer reload a project, after saving it, if one has an audio track in the project.

I note my desktop (just before I went on vacation) did not have this behaviour. Has anyone else encountered this?

When I get back from vacation, I’ll compare the packages between the two (ie between laptop and desktop). I note these packages on my laptop, which may or may not be relevant.


No idea. But notice kdenlive 0.7.8, mlt 0.5.10 and frei0r-plugins 1.2.0 have been recently released. And openSUSE’s sox lacks MP3 and ffmpeg support.

Oldcpu, I have a similar setup on opensuse 11.3 x64 HP DV7 laptop but with KDE 4.5 (release 3) stable and packman multimedia files. I’m sure you have latest ffmpeg from Packman too?
I’ve managed to edit/cut video, add audio (mp3), save and load kdenlive project files with kdenlive
I have not have experianced the same problem with not being able to load kdenlive projects unless I have moved the media files to a different/new location.

I note my desktop running openSUSE-11.2 does not have this problem. I do not believe any of my other PCs back in Europe (running openSUSE-11.3) have this problem with kdenlive. When I get back to Europe on the weekend, I compare configurations. …

I have this ffmpeg version on the laptop:

My internet connection here is very slow (a slight step above dial up), so I’m not inclined to do any software updates until I get back to Europe with a faster connection.

I’m back in Europe, and I tested this on my 32-bit openSUSE-11.3 PC to see if it could reproduce the problem (where the problem is on a 64-bit openSUSE-11.3 install on my laptop). My 32-bit openSUSE-11.3 PC does not have this problem and can not (yet) be reproduced on that desktop, although the laptop with a 64-bit openSUSE still has the problem. I note the desktop (that functions) has this configuration:


other than 32-bit vs 64-bit, the versions are the same, except the desktop (that works) has an older version of mlt than the laptop (which does not work). ie with MLT version (build 1.13) works on the 32-bit PC while with MLT version (build 1.16) it does not work on the 64-bit PC.

I’m thinking that the MLT difference may not be the issue, and so I am going to update MLT on my 32-bit PC to 'build 1.16" to confirm it still works, which would then suggest/point the finger to a different (as of yet unknown) problem.

RedDwarf, if I can’t sort out getting kdenlive to work, I’ll update to kdenlive-0.7.8-9.4 rpm from your repository (or what ever the latest version may be when I get around to it). I’m puzzled as to what I did to cause this hiccup on my laptop, as normally I am fairly careful and do not run into such problems.

Once I sort this a bit further, I’ll post what I have learned (if anything).

My investigations did not get very far … as I can no longer reproduce the kdenlive crash problem on the 64-bit openSUSE-11.3 PC. I’m a bit taken back, as I did not change much, and what I did change does not make much sense to me that it could have had anything to do with the problem.

I first encountered this problem 6-days ago with an older version of mlt than I reported (but not as old as the build 13.1 on my 32-bit PC). After encountering the problem, I had then (without rebooting) updated mlt on the laptop to the build 16.1 on the laptop (and also libmpeg123 - which I think not relevant), and I tried kdenlive and I still had the problem. I tested my ability to reproduce the problem many times with the laptop running (no reboot done), and it was flawless in that I could always reproduce it. I posted my efforts, and then ceased attempting to fix this with the laptop. Two days ago, on 24-Sep I updated the graphic driver on this laptop from the radeon opensource driver to the latest Catalyst-10.9 proprietary driver (this laptop still has the older 2.6.34-12 kernel).

I also updated wine since then (which is irrelevant) and removed and reinstalled under wine the program virtualdub with the deshaker plugin (and some codecs/Microsoft apps all under wine - again, not relevant to kdenlive).

And that’s all I have changed.

I went today to reproduce the problem as part of my investigations, and I could not. It had disappeared.

All I can figure is there are two possibilities for an explanation, of which the second is most likely and the first not credible (in my view):

  • switch to 10.9 Catalyst solved the problem - extremely unlikely …
  • rebooting the PC after 20-Sep problem encounter … some process must have been crashed on the laptop when I encountered the problem … this is most likely. I’m not in the habit of rebooting on Linux to see if that fixes a problem (and I did not try that on 20-Sep), but that is the most likely explanation. Some Linux audio or graphic driver process may have been corrupted, and it may have caused the problem. In hindsight, I should have attempted restarting the alsa driver, and maybe even rebooted on 20-Sep, to be certain no errant process was the problem.

My apologies to all on this thread for the wasted bandwidth. I feel somewhat embarressed by this, as I don’t think I normally make such mistakes (which are typically new user classic errors).

Oldcpu, if you would like to take advantage of updated kdenlive and mlt Toni has uploaded these on Packman today. There are a number of nice new features i.e. Photo Pan Zoom effects etc

Thanks for the notification. Toni has been great in the packaging contributions he has made to openSUSE !!

I updated my wife’s PC’s kdenlive earlier today, and plan to incrementally do each of my PCs over the course of this week to the newer kdenlive-7.8. I note mlt is also updated to version 05.10 at the same time.

Early this evening I was playing with composites (for titles) on the older kdenlive-7.7.1 , creating some text and then have the text scroll up the screen. It takes a bit of practise, but once one gets the ‘hang of it’ I find that such an effect works ok and looks pretty neat ! Here was an early effort with kdenlive-7.7.1 on openSUSE-11.3 (created on a 32-bit athlon-2800 PC): https://www.youtube.com/watch?v=MyeuGdXv4XM)

I also created a video of my brother-in-laws new restaurant in Khao Lak, Thailand, when I was there a couple of weeks ago. Video is here: https://www.youtube.com/watch?v=dG-eZ2itPq4)
I took those video clips with my Canon HF S10, and stabilized the videos with VirtualDub with the Deshaker plugin running under wine on openSUSE-11.2 (and kdenlive-7.7.1) on my Intel Core i7 920 pc.