kdenlive 15.04.1-6.1 from packman - segmentation fault

Hi. I’m on opensuse 13.2 KDE 4.14.3. I did a “zypper up” yesterday, which installed kdenlive 15.04.1-6.1 from packman, along with a bunch of new dependencies. Kdenlive worked fine previously, but now gives fails to start (segmentation fault). I could use some guidance on how to track down the cause/solution?

Most likely a problem with your Melt installation if it did not update as well. You’ll need Melt compiled with QT5 to use newer kdenlive based on KF5.

Thanks for the reply. It seems odd that the packager would provide a package that does not work with the current version of melt in the repository. But more to the point, I have some doubts that this would cause a seg fault at launch? Seems more likely that that issue is somehow related to the rendering of the gui.

Honestly, I was surprised to see that kdenlive updated, as I have seen the other threads here that discuss the difficulties with the shift to plasma 5.

Hi
Sometimes it can help to check the packman mailing list and also report issues direct…
http://lists.links2linux.de/pipermail/packman/2015-May/013589.html

It will be dropped from packman for factory by the looks…

Yes.
In short, this happened by mistake, and is fixed already. The old KF4-based kdenlive should be in the repo again in a few hours, but you have to downgrade manually.
Or you can also install kdenlive 0.9.10 from KDE:Extra. Kdenlive is basically just a frontend to libmlt, so you’d still have full codec support.

And yes, the crash is indeed due to a Qt4/Qt5 conflict.

Thanks folks, all very informative and helpful!

It won’t be dropped.
From now on Packman will offer the KDE4-based kdenlive 0.9.10 for <=13.2, and the KF5-based 15.04.x (and higher) for Factory/Tumbleweed and future openSUSE releases.

Btw, 0.9.10 is in the repo again meanwhile, but as mentioned you will have to downgrade manually, e.g. by right-clicking on the package in YaST and choosing “Update Unconditionally”, or by running “sudo zypper in -f kdenlive”.