Kdeinit4....check installation?

I have a dual install, openSUSE 11 and vista, running on my laptop. When I turn it on it goes to OS selection screen through grub and I choose my default (it does the same thing on any choice except Vista). Then it goes to the openSUSE loading screen (green screen little white bar slowly fills up) but a little ways in it flips to a blank screen and gives me a message about the kdeinit4 and that I should check my installation. I am not sure what to do from here. This worked on this laptop for about three weeks now and I did not change anything yesterday when I had it up and running. Thanks for the time and the help!!

have you a text login?
if yes then logon as root (or as user and then su) and run yast
from software menagment reinstall or deinstall kde4 stuff and see what is going on

Ok when I pull up all of the KDE4 stuff there is a ton of it. Should I really uninstall all of it? It seems like maybe this will cause instability in the system or maybe cause it not to function, I could be wrong.

So I also saw another post in another thread that told me to update all packages through yast, I did this and it did not help. I just ended up spending forever waiting on it to install a bunch of different things. So I am still lost and I don’t know if I should go ahead and uninstall anything and everything that says KDE4 on it or if there might be a better way. Thanks everyone in advance for the help!

kde4 is still not ready for use although the last update is pretty stable on my system
hopefully, in the end of month we’ll see the final kde 4.1 that should be ok for end user
and last, opensuse 11.1 in the autumn will bring it with all suse extras :slight_smile:

i would suggest you to install kde 3.5 from repos to make the system run and it’s up to you leave or remove kde4

Ok I am new to linux and I need you to be a bit more step by step here. I have been able to follow most of the time but it takes me a bit. I can run Icewm & something called TWM but I cannot get into KDE4 still. So how do I go about taking ALL of the KDE4 stuff off. I have been able to remove a couple of components but there is a ton of stuff in yast software management and I think that is not where I am supposed to be anyway. Point being if you could just tell me the easiest/ most correct way to uninstall the kde4 it would be fantastic!! Thank you for your help!!

i’d advise you first to install kde 3.5

go to yast -> Software menagment and install patterns KDE3 Base System and KDE3 Desktop Environment
after finish logout and from Session type at login screen choose kde for kde3. kde4 is for kde4 :slight_smile:
if it’s ok add kde 3.5 repos from
KDE/Repositories - openSUSE
you need kde core and kde backports. other 2 are optional

removal of kde4 could be tricky because some applications like ktorrent3 use base kde4 libs
pay attention that kde3 and kde4 don’t interfer so you can have both of them

unfortunatelly patterns kde4 base system and kde4 desktop environment offer packages not related to kde4 that you are likely to use
so uninstalling these patterns is not a good idea :cool:

if you still want to go ahead then search for kde
will get list of all kde3 and kde4 packages

carefully scroll the list and select for deletition kde4 ones
kde4 packages are named with kde4ABC or kdeABC4
kde3 - kde3ABC or kdeABC3
need to remove a couple of libkdeABC4 packages too

very likely you’ll get prompts for missing dependencies for some applications
one approach is to leave the needed kde4 rpms
or delete them alltogether with applications and later install the applications back. they will bring for autoinstall the needed kde4 libraries.

one more time - if unsure just leave kde4 and use kde3 untill kde 4.1 final release is out :slight_smile:

hi To All

I have the same problem with Kdeinit4 The problem
Is caused by the latest update.

I have no Idea how to cure it Suse want shooting.
do they not test before downloading this stuff.

the time and effort wasted trying to get it back
without reinstalling is beyond believe.

Is there a way to remove the updates and still keep whats installed

thank you Rushman

Hi from rushman,

Hi here is a work around that I have used on my Lenova Laptop

new Installation,
Kde4 selected
update will bring you to the repos
only tick ,Packman,nvidia or Ati,X11,videolan

When the update panel comes up de select the KDE ones

on re boot you will find your home directory is still.intact.

best of luck


Hello all,

I just ran into the same KDEINIT4 problem this AM when I performed the updates, I haven’t updated in a few days so I’m not sure which update fubared the system.

Without doing a reinstall, is there a way to work around this, as I am unable to get into my system?

If this is a common issue, with many having this problem with openSUSE 11 KDE4, I can’t see how this got past the testing phase.

If it helps, I am running the following hardware:

AMD 64 3800+
ATI Radeon x1600
2 gigs RAM


I had the same problem last night when I ran updates. Good thing I always install Gnome with KDE. My cmd line skills are not the best. I like KDE better than Gnome so I installed KDE3. Everything is working OK, but I disabled all my repos until I have time to go through the forums.

What ticks me off the most is I really like KDE 4 over KDE 3. I just like eye candy.

I fixed this problem when i updated the “libkde4” package through yast in the x console as root.
it will bring KDE 4.1.00 (KDE 4.0.99 (4.1 RC1+)) “release 13.8” updates to you.
best of luck!

Worked great. For newbies…
Attempt logon… you should get the error and be at menu/logon screen.
From Menu select Console Logon
You will now be at a command line screen
Logon as root (or use SUDO)
Type: yast --update libkde4
Reboot: shutdown -r now

Note: You will need the openSUSE CD/DVD

PS… Totally not happy that this slipped by any sort of QA but glad that the fix was this easy. Thank you so much for posting this fix, I was not looking forward to a reinstall (even if I can keep my home folder).

This would work fine if I would have the installation cd’s, but I installed SUSE using the live cd and so it tries to connect to the internet to download the files which is not possible without kinternet (connection).
I must say that I cannot believe that SUSE let that slip through without checking. Lets see how Fedora works!!!

I was online and saw they released KDE 4.1 Released With openSUSE Packages and Live CD at

openSUSE News » KDE 4.1 Released With openSUSE Packages and Live CD

I ran the install via 1-click. KDE 4.1 is installed!! :slight_smile:

I like the fact I can change the size of the Kicker bar (Status Bar) and some of the other improvements listed at

K Desktop Environment - KDE 4.1 Release Announcement

As usual, you have all been very helpful and I have successfully solved my problem thanks to you!! Thanks everyone for your time and tips!!

I ran into this same issue. Am currently d/ling the kdelibs set. I hope this works, as I was poking about and could not find a solution.

ICE is fine, but it’s no KDE…and I am not a big fan of gnome.

Worked great. For newbies…
Attempt logon… you should get the error and be at menu/logon screen.
From Menu select Console Logon
You will now be at a command line screen
Logon as root (or use SUDO)
Type: yast --update libkde4
Reboot: shutdown -r now

This did not work for me, and I got the same error.

What about the CD? Did I miss a step that wasn’t explained fully?

Just a note. Even months after this thread was initially posted, the problem still has not been resolved but this fix still works.

Installing OpenSuSE 11.0, with KDE 4.1 repositories added.

Yast Online Update from the taskbar fails, but running Yast Online Update from within Yast permits you to skip problem updates. I didn’t check what were the last 2 of 3 updates that were skipped, curiously the first one was an update to Yast itself due to some permissions problem.

With the first reboot, the dreaded KDEinit4 error.

Selected Console Logon which was hung looking for a file that didn’t exist, CTL-C to escape to a Prompt.

Executed the recipe updating libkde4

Completed running YOU through YAST which included another reboot and eventually all patches are successfully installed.