KDEInit could not launch 'MozillaFirefox'.:

When clicking on any hyperlink in Kontact, I get the following error:

Could not launch the browser:

KDEInit could not launch ‘MozillaFirefox’.:
Could not find ‘MozillaFirefox’ executable.

KDE is 4.6.0 “release 6”
Kontact is 4.4.10
Firefox is 5.0
Running OpenSuSE 11.4

Standard install, nothing fancy, just like to use Kontact. Tried checking External and default browser - NADA.

Pointers to the “executable” much appreciated!

Hello Harleyb,

Try setting the executable in System Settings->Default Applications->Web Browser.
Make sure “in the following browser:” is checked and enter firefox in the input field.

Good luck!:wink:

Sorry to be dense, but what “System Settings->Default Applications->Web Browser”, where? I can’t find any of this in Kontact.


Hello Harleyb,

System Settings is a different application, by default it’s in your favourites in the application launcher (left-bottom corner).
If it’s not you can find it using the search bar at the top of the launcher.

Good luck!:wink:

This is a completely wild guess.

In my Desktop folder ("$HOME/Desktop") there is a file with name “MozillaFirefox.desktop”. It is the only thing I am aware of that uses the name “MozillaFirefox”. Perhaps Kontact uses that to launch a browser. You might check whether you have that file, and if you have it, whether clicking on it launches firefox.

Yeah, if you click on it, it starts Firefox, but putting it into Kontact doesn’t produce the desired result.



Worked for me. thanks.


have you tried setting this?

SUSE Paste

you shouldn’t need to make any setting changes in kmail/kontact