Is there going to be an official release of KDEConnect for Leap 15.3?

If not, is it safe to install the 15.2 release?


Is it safe to install an unofficial release? The unofficial release I looked at seemed to require changing a lot of the 15.3 KDE files.


After upgrade from 15.2 to 15.3 i see the version below.

 LANG=C zypper info  kdeconnect-kde 
Loading repository data... 
Reading installed packages... 

Information for package kdeconnect-kde: 
Repository     : Haupt-Repository 
Name           : kdeconnect-kde 
Version        : 20.04.2-bp153.3.24 
Arch           : x86_64 
Vendor         : openSUSE 
Installed Size : 4.2 MiB 
Installed      : Yes 
Status         : up-to-date 
Source package : kdeconnect-kde-20.04.2-bp153.3.24.src 
Summary        : Integration of Android with Linux desktops

Thank you. Maybe I shouldn’t have uninstalled the 15.2 version (I’d had a problem with it). By searching for version details I found an official package in Repository openSUSE Oss x86_64 :


https://software.opensuse.org still shows no official kdeconnect package for 15.3 - they were cautioning against using the unofficial packages. But now I’m confident enough to go ahead.

As far as i understand it Leap 15.3 is using the SLE 15 backport RPM for kdeconnect-kde. And this might be the reason why there is no 15.3 package at https://software.opensuse.org. If you use zypper or Yast to install kdeconnect-kde you will get the official 15.3 version from the official oss-repo.

Thanks again rawar.

I am in no way a geek but I had tried zypper and YaST first. And Kdeconnect is not in my oss-repo.

The only option I got from YaST was to install kdeconnect with vendor change (which would mean the installation of 130 packages from obs://build.opensuse.org/KDE )

I tried to install kdeconnect via opi and was given the following options:

  1. KDE:Unstable:Applications ? | 21.07.70git.20210708T0119 | x86_64
  2. KDE:Applications ? | 21.04.3 | x86_64
  3. home:mrbadguy:KDE5 ! | 21.04.3 | x86_64
  4. home: lasmaregataos ! | 21.04.2 | x86_64
  5. home:msvec ! | 20.12.3 | x86_64

Should I have chosen “2”?

I’ve obviously done something wrong but I don’t want to mess with a perfect system. I’ll leave it and wait for an official release from https://software.opensuse.orgSigh.

AFAIK there is an official package. I have here:

:~> zypper info kdeconnect-kde
Carregando dados do repositório...
Lendo os pacotes instalados...

Informação para pacote kdeconnect-kde:
Repositório             : Main Repository
Nome                    : kdeconnect-kde
Versão                  : 20.04.2-bp153.3.24
Arquitetura             : x86_64
Fornecedor              : openSUSE
Tamanho após instalação : 4,2 MiB
Instalado               : Sim
Status                  : atualizado
Pacote fonte            : kdeconnect-kde-20.04.2-bp153.3.24.src
Resumo                  : Integration of Android with Linux desktops
Descrição               : 
    A package for integration of Android with Linux desktops.

    Current feature list:
    - Clipboard share: copy from or to your desktop
    - Notifications sync (4.3+): Read your Android notifications
    - Multimedia remote control: Use your phone as a remote control
    - WiFi connection: no USB wire or Bluetooth needed
    - RSA Encryption: your information is safe

    Please note you will need to install KDE Connect on Android for this app to work:
    https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp or

It came from the main repository, set during install as http://download.opensuse.org/distribution/leap/$releasever/repo/oss/

https://forums.opensuse.org/showthread.php/546292-What-is-the-difference-between-releasever-and-releasever?p=2977405#post2977405 explains where the actual version number comes from.

Thanks everybody. I just did a clean install of Leap 15.3 and kdeconnect was installed as you said it would have been.