KDE5 taskbar crash and black screen/ freeze

btw i am using lenovo T410 with opensuse Leap installed.
recently the taskbar is missing after re-login from unlock screen.
sometimes i the screen went black then followed by shutdown.

i check the log to find some error line, here is what i found

 5566.015307]  sdb: sdb1 sdb2 sdb3
 5736.074124] perf interrupt took too long (2519 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
 5852.719737] [drm:ironlake_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
 5852.719781] [drm:ironlake_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
 7993.941497]  sdb: sdb1 sdb2 sdb3
 8103.812941] [drm] GPU HANG: ecode 5:0:0xf7fffffb, in X [1396], reason: Hang on render ring, action: reset
 8103.812945] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
 8103.812946] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
 8103.812947] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
 8103.812947] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
 8103.812948] [drm] GPU crash dump saved to /sys/class/drm/card0/error
 8103.813009] drm/i915: Resetting chip after gpu hang
 8114.822428] drm/i915: Resetting chip after gpu hang


pulseaudio[1940]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error

i have tried to search on google, most of them will solved just by edit intel driver conf…
but my laptop use different driver, its xf86-video-vesa, and i coulnd’t find vesa driver configuration.
i dont know if my problem related to type of vga driver that i use (vesa)…
or should i change my vga driver, remove vesa driver and install xf86-video-intel driver?

here is my vga specs

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
        Subsystem: Lenovo Device [17aa:215a]
        Kernel driver in use: i915
        Kernel modules: i915

And why do you think so?
These error messages come from the i915 kernel driver, which wouldn’t be in use with vesa, which is just a generic fallback if no other driver is found.

Please post your /var/log/Xorg.0.log .

i’ve never choose vesa driver, and there was no specific notification to install specific driver while installing opensuse.

sorry i put Xorg.0.log on pastebin

Well, if you never chose it, why should it be used?

According to you log, your system is using Xorg’s built-in “modesetting” driver, which is preferred to xf86-video-intel nowadays especially on newer hardware (the intel X driver is just to buggy).
Still uses hardware acceleration though.

Your error message comes from the kernel module as I wrote.
Might be a bug in the newer one from drm-kmp-default (backports from kernel 4.9), so try to uninstall that package.

You may also try to install xf86-video-intel, maybe it would give better results.

Other than that, you should file a bug report, as the error message tells you.