kde5 spellcheck in multiple languages and other language issues

with KDE 4 things where simple, I installed aspell I needed, no language packages for KDE, I could set regional setting to what I wanted,
I had a english UI, regional settings I wanted, and spell checker I needed.

With KDE5 is sucks like it does in Windows.
When I set regional settings, all the sudden the whole UI language changes, I did not ask for that.

And for getting spell checker, I need to set preferred languages, what I did


in this order

so why do I have German zypper messages?

this is so unbelievable stupid, it worked so good with kde 2/3/4 and 5 messed all up. why?

I want a english UI
swedish date time and numbers (regional settings)
and english/german/sedish spell checker,

why is it all the sudden super complex to get this and it does not work when it was super simple and it worked great?

what do I have to do that I have the settings I want? Please help

why are all konsole messages and help text from programs german when echo $LANG gives me en_US.UTF-8 ?

edit , I removed the preferred languages German an Swedish since they are not required for the spell checking, it seems installing aspell and than log out / in is enough.

now my help messages on the console are english again, but my UI is in mixed language , English and German, how is this possible? (yes, I logged out/in)


I am afraid that people here can not answer your questions. There are several threads here were people air their frustration about not being able to get their environment as they had it for years (search e.g. for: display date in ISO).

The best place to go is IMHO: https://forum.kde.org/
or even: https://bugs.kde.org/

Yes, yes, KDE Plasma 5 is not the same as KD4 Plasma – especially with respect to Spell Checking.
And, applications such as Firefox complicate the issue . . .

  1. Make sure that the dictionary for your wished for language is installed – ‘aspell’ and/or ‘ispell’ for KDE and ‘myspell’ for Firefox.
  2. Right click in the text entry part of the active window and select “automatic spell checking” and the preferred language language – alternatively, press the “Menu key” (keyboard lower right, to the left of the right hand “Ctrl” key).
  3. Be aware that, KDE applications such as KMail2 automatically change the spell checking language on a sentence by sentence basis, assuming that, the appropriate dictionaries are installed – type an English sentence, and then a German sentence, and then a Swedish sentence – the Spell Checker will automatically select the correct language for each sentence being typed.

Users should always set their preferred language in the “~/.profile” file:

# Most applications support several languages for their output.
# To make use of this feature, simply uncomment one of the lines below or
# add your own one (see /usr/share/locale/locale.alias for more codes)
# This overwrites the system default set in /etc/sysconfig/language
# in the variable RC_LANG.
#export LANG=en_GB.UTF-8
export LANG=de_DE.UTF-8 # uncomment this line for German output
#export LANG=fr_FR.UTF-8        # uncomment this line for French output
#export LANG=es_ES.UTF-8        # uncomment this line for Spanish output

On this German (system) language machine I have Test users which use the default KDE User set-ups, including an English language user with “export LANG=en_GB.UTF-8” activated in the “~/.profile” file – works a treat . . .

thanks, i will consider registering on these places and provide my feedback there an option

no problem with firefox,

that I needed to log out and in with KDE to be able select a newly installed word books is windoresk.

as written, my LANG is and was en_US.UTF-8, what makes it twice surprising that KDE shows me German text

Then, the issue is, possibly, in the KDE “System Settings” -->> “Personalization” -->> “Regional Settings” -->> “Language” -->> “Preferred Languages:”

there have been multiple languages but in order, english german swedish, but than I removed german and swedish after my console messages changes languages,

there is a own LANGUAGE environment variable KDE sets, it was to the 3 languages when the germal konsole messages apperar, but no idea why, German was in the middle of those languages, no idea why the gui was still english while konsole messages became german. this is maybe a bug.
and why later the gui had dual languages … software :slight_smile:

now, after some days, and removing the additional languages, all non English texts are gone, so maybe just some caching issue with stuff in /var ?

More likely in '~/.cache/" . . .