kde4init symbol error on libXinerama.so.1


Since an update last weekend KDE refuses to start. I’m getting the following error:

Startkde: starting up...
/usr/bin/kdeinit4: symbool lookup error: /usr/lib64/libXinerama.so.1 undefined symbol: _XGetRequest
startkde: Could not start kdeinit4. Check your installation
xinit: connection to X server lost. 

I’ve already deleted my .kde and .kde4 folders but no result.

Please help

Are you using multiple monitors?

Technical Yes, but since I had some troubles, months ago and the Xorg driver is not supporting 2 monitors. I cleaned my Xorg.conf and working on one monitor.
But I have 2 videocards in my system.

Everything worked fine until last weekend.

You might want to check if the libXinerama library is up to date. It is in the xorg-X11_lib package. Might try a reinstall of the package. Note requires a reboot.

I thought that is one of the libraries that was updated. Bur since today there is a new kernel update en the symbol error is solved. Now X can’t find my screen, found that X cleared all the conf files again. So I fixed the Xorg.conf and now I also get a device error too. It seems that the open amd driver isn’t supporting my graphics card. But it’s 1.3.0-… and it was working before.

Can somebody explain what is going wrong, still haven’t a working system.


When updating to 12.2 I had the same problem and stumbled across this thread.

Here’s what I did to solve the issue:

  1. For some reason package libX11 wasn’t installed -> installed it.
  2. x11 drivers for AMD gpu’s was however installed (I have nvidia gpu) so I deleted it.

Now X11 is running.