KDE4 wont save style or it just resets


I have made video to make it more easy to understand:

The problem is that when i save “Oxygen style” all windows changes to Oxygen correctly with its colors, scrollbars, etc… but as soon as i close aplication and start it again, the style resets to GTK+. this reset is not wisible in dropdown box of styles, but after reselecting oxygen and hitting apply, the style changes to oxygen.

When hitting apply console says:

erik@linux-rwt0:~> X Error: BadAtom (invalid Atom parameter) 5
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x0

Thank you

Sounds a bit like this:

Could you try to remove the file ~/.config/Trolltech.conf (preferably outside of KDE)?
Maybe the global Qt style is set to Gtk+ in there.

Otherwise a bit more information about your system wouldn’t harm as well, like which openSUSE version, which KDE version, installed from where.

OpenSuse 13.1, fully updated, originaly installed with XFCE then i installed KDE from software mannager -> patterns. after that uninstallled xfce.

Linux linux-rwt0.site 3.13.2-1-desktop #1 SMP PREEMPT Thu Feb 6 20:59:14 UTC 2014 (7e6b5de) x86_64 x86_64 x86_64 GNU/Linux

*rm ~/.config/Trolltech.conf *
worked perfectly.

My googling is last time something horrbile. I will take more care about it to do not ask so simple questions…

Thank you. +1

Well, I guess that wasn’t so simple anyway.

I just happened to remember that bug report because I tried to help the reporter with his problem here in the forums… :wink:
And yours sounded similar.

Thank you again… :_)