KDE4 update problems, some solved, one not

This morning I began having problems with Kwin Desktop Effects, so I decided to reload Kwin. I went into Yast>Software Manager, did a search for kwin, changed the “installed” check mark to the “update” check mark and clicked on the Accept button.

I was very surprised when I got done to realize I’d actually triggered an unexpected upgrade of KDE from 4.2.2 to 4.2.86 (I’m a little confused though, 'cause there are a lot changes and I’m not really sure what "4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514)) “release 125” " means)

The initial result was a complete disaster. I won’t even try to list all the problems I had, but the solution was pretty easy (once I got over my panic). I simply used YAST and repeated the same update of Kwin. When I did that I found that the first update had been incomplete. When I redid the update it not only solved almost all the problems I’d seen, but I’m now able to use Compiz effects for the very first time ever without crashing my PC, WOW!!

If you happen to find yourself with a disaster after updating KDE, try updating twice; it may not seem logical, but it worked for me.

One minor annoyance remains though. There used to be a handy little icon at the right side of my panel (probably a “widget”) that always gave me a quick visual indicator of the status of my network / wifi connnection. When the connection was down it was a round version of the knetworkmanager icon, when I was on a cat5 connection it changed color, and when the wifi was working it changed to a little picture of signal strength bars. That icon has dissappeared and I’m at a complete loss to figure out how to get it back. It’s not listed under “add a widget” or anywhere else I can find.

Anybody know if that icon is hiding somewhere that I haven’t discovered?

Right, you’re still using the Factory repositories. You don’t want to do that as now they’re housing the KDE 4.3 packages. To use the 4.2 repositories read this thread.

KDE4.2.* (How To Add) Guide. - openSUSE Forums

Good Luck,


And that network manager is the kde3 network manager. You might have uninstalled it if you had all those conflicts. First get your repositories correct by removing your factory repositories and adding the repositories from the thread above. Then to get the network manager back you’ll need to reinstall KnetworkManager. Not the KDE4 version.

Good Luck,


Yes, you have upgraded to 4.3

If I remember rightly in 4.3 the network manager is a widget called something like Network Management. It can be added to the panel with the add widget menu.

Note: I just deleted it from mine because it was causing plasma to crash at startup (It’s bug reported at KDE).


If you’re wanting a more stable desktop you should probably downgrade to 4.2

Oops, you’re right I did have the Factory repo enabled. I can’t imagine why, and I honestly can’t remember doing so. I’m now pretty careful to only have four basic ones enabled. I thought I’d learned the hard way the first time I got in similar trouble, but I must have had a brain cramp.

Nevertheless, I’m going to hold off a little while before I roll back simply because this is the first time I’ve had a useble desktop on this particular PC with either kwin or compiz effects running. It’s been about six hours now and I haven’t had to recover from a crash :open_mouth: Of course it’s still way too soon to be sure, but I’ve got my fingers crossed.

I do hope something like that old widget gets brought back. It was awfully nice to have a quick and dirty way to check and see if the network is up and/or if I’m near enough to the wifi.

I’ll try to remember to post an update in a couple of days when I know whether this version is stable enough to use.

thanx for the help!

update: still some freezing with compiz only, OK with kwin though. Otherwise no problems, overall I like it so far.