kde4+tomboy search problem.


I’ve got an opensuse 11.2 running with kde4. In the office I use a lot the tomboy app, but my problem is since I upgraded the system (from 11.1 to 11.2), when I start tomboy all is fine… except the search field into the tomboy aplication.
I can search throught hundreds of notes, open and modify it, but I’m not able to make a search into the tomboy notes.

Anybody know anything about that?

Thank you very much.

Hi, I’m not totally sure I understand your question. Could you explain it a little bit more?

In Tomboy, you can open the Search All Notes window to search through every note, and you can also press Ctrl+F while in a note window to search for text only in that specific note.

What exactly are you trying to do?

Sorry, my fault and my lack of a more deeper knowledge in english…

You make click-left over tomboy icon, this show you a menu with the Search in All Notes option. When you select this option a windows appears with a Search field, and under this field an “inside window” with all of your records.
Ok. In my tomboy app, the field Search appears with a grey colour (the same color like the menus of this window), and I cannot able to put any text inside it.

I will apologize about my bad english… sorry.

Thank you very much.

And I forgot another thing; if I try to make the same under Gnome or IceWM, tomboy runs fine and I can able to make search under all of my notes.


I’ll try to look into this this weekend. I’ll have to install KDE4.

Even though the search field is grey, are you sure you can’t enter text in it? This seems so strange!

Yes, without any doubt. Do you think I need to open a bug report in opensuse’s bugzilla?

Thank you!

Also, if you thing that this is relevant, the system is an i586.


Yes, filing a bug could be helpful. If you do so, please share the link here. :slight_smile:

same here. Worked fine under 11.1 with 4.3.3 but after upgrade to 11.2, search field is grey.
It’s something to do with 11.2, not KDE, i guess.
I installed and reinstalled a few versions, even 1.1, problem still there

But curiosly, if I change the session (to icewm or gnome), tomboy works fine… It’s like something goes wrong with anything of kde4.


I open a bug #557611


For anyone with this annoying bug, you can work around it by running this command from a terminal (or the alt-f2 prompt):

tomboy --search “my search phrase”

I’ve reproduced the bug in a KDE VM, and will try to figure out what’s going on. In the meantime, the above command should work fine.

thanks!looking forward to a fix, cause i had just moved from kjots to tomboy a few days ago due to the instant search feature, mainly!

any update on this issue? It’s been over two months now and i would really love to have tomboy back!

The “patch-solution” is exposed in this thread. I don’t know at this time if the based problem was solved. By the way, you can look the bug state that I was reported (bug #557611).
Sry for my bad english…


Have a nice day :wink:

thanks for the quick reply. Unfortunately using konsole as suggested in this post is not really an answer for me. I switched from kjots to tomboy for the instant search feature and having to type the search from konsole each time is not instant search.
However i saw in the bug report the hint about changing gtk theme to clearlook, and there it is!!! It’s working!
Not sure which other apps this might influence (no idea which are gtk apps anyway) but thanks anyway!:wink: