KDE4 sound system and .wav files?

Is it common that the KDE4 sound system has trouble playing .wav files?

It plays the first half second of the file and then stops.

I’ve had this problem for a long time, just ignored it as I don’t use many system sounds.

Any ideas on how to fix this?

Thanks :slight_smile:

No that should not happen. And I have no idea to fix based on the information provided. You could provide more information, and then maybe someone could guess at this. ie please tell us what

  • openSUSE version
  • exact KDE version
  • what media players you have attempted this with?
  • did you try the very basic "aplay -vv somefile.wav
    " ?
  • have you tried different .wav files or just the one?

Edit - if this is just the system start-up / shut-down system sounds, then thats a different kettle of fish, and I can’t help there.

there must be something wrong with your system or the wav file - as opensuse can happily play wav files out of the box

have you tried playing different wav files

have you tried using different different programmes to play the song

does sound work in general

No, not playing wav files in general, as that works without a problem.

This is an issue with the KDE sound system, ie the startup/shutdown/error/notification sounds. The ones you can assign from the control panel.

So I guess it’s a KDE4 problem.

As I said, it has been happening with all versions of KDE4 that I’ve ever used, hence me not giving specific version numbers.

I was just hoping somebody else had found a fix for the problem.

It happens with ALL .wav files.

I don’t have this problem with my sandbox PC and KDE4, nor with my laptop PC with KDE4 , nor with my wife’s PC with KDE4.

What have you done to try to investigate it ?

Did you go to kmenu > Configure Desktop > multimedia > Backend and try a different backend? I have xine selected. What do you have selected. I also note my xine (via the xine-ui control) has alsa selected and not pulse.

Also, under kmenu > Configure Desktop > multimedia > device preference > audio output, one can select the order in “output device preference for the Notifications category”. … Is there anything you can tune there?

Take a screen print of your settings BEFORE you change anything, so you can restore it afterward if it does not work.

I just had a look oldcpu, and I have ONLY xine in there, nothing else.

It reports version 0.2.60, and zypper reports version

The notifications option (I guess that means system sounds) has either HDA Nvidia Conexant analog, or Pulseaudio as options, but selecting pulse gives an error about it not working and switching back to Conexant analog.

The .ogg system sounds play perfectly, as does the test function, it’s only .wav files that give me grief.

Under Backend, I have no idea what Deinterlacing method does, should I try messing with that? It has only DVD checked and use_vo_driver selected.

You can try it to see if it works properly on your system by opening - kmenu > Configure Desktop >Notifications > System Notifications > Applications.

Select K3B as the application, select Process Successful, then click on the play button to test it.

That test plays the default K3B sound k3b_success1.wav, and on my system it plays the first half-second of the sound then stops.

This is all on openSUSE 11.2 RC2, but it has done it with both the KDE3 and KDE4 versions of K3B under ALL versions of KDE4 that I can remember.

I’m sure the K3B sounds work perfectly under KDE3, although I can’t test that to be certain.

I never use that feature. It does appear buggy. I recommend you write a bug report on it. There is guidance here for raising bug reports: Submitting Bug Reports - openSUSE

Thanks oldcpu, bug submitted.