kde4 network manager plasmoid doesn't work.

Hi there and thx for answering if you can.

I have just upgraded my opensuse x86_64 to 13.2 with KDE4. The process worked fine, but when I log in my kde4 session, the network manager plasmoid is frozen: I can see the surrounding wifi hubs, but refuses to connect to my usual modem, with the following message box:

Failed to add connection
No session found for uid 1000 (unknown)

My connection editor shows up an empty list. Moreover, the uid 1000 is my current user and is not unknown at all.

However, when I log out and relog in, everything works as usual: I’m automatically connected to my modem, and everything is ok.

wicked &Co are down and NetworkManager is up.

Any idea ?

Doesn’t seem to be due to the plasmoid.

When I issue a : **nmcli device connect wlan0 **, I get the same error message. Polkit or dbus problem ?

I also got the nm permissions:

nmcli general permissions

org.freedesktop.NetworkManager.enable-disable-network auth
org.freedesktop.NetworkManager.enable-disable-wifi auth
org.freedesktop.NetworkManager.enable-disable-wwan auth
org.freedesktop.NetworkManager.enable-disable-wimax auth
org.freedesktop.NetworkManager.sleep-wake auth
org.freedesktop.NetworkManager.network-control non
org.freedesktop.NetworkManager.wifi.share.protected auth
org.freedesktop.NetworkManager.wifi.share.open auth
org.freedesktop.NetworkManager.settings.modify.system auth
org.freedesktop.NetworkManager.settings.modify.own auth
org.freedesktop.NetworkManager.settings.modify.hostname auth

No problem here.

I think that “session” message might be referring to a systemd user manager session

rickert   2221     1  0 Nov08 ?        00:00:00 /usr/lib/systemd/systemd --user

Polkit authentication seems to depend on communication with that user manager. You might check whether the relevant process is running. I used:

ps -ef | grep user

to find that process.

Ok, first time I get **root **as running user for /usr/lib/systemd/systemd --user
then, when I logout and relogin, I get my nominal user.

Now where this systemd --user is launched ?

Ok, found something in /usr/lib/systemd/system/user@.service
but it doesn’t explain why I got root the first time I log as my personal user, and the correct uid when I logout and relogin

I’m pretty sure that it is started by the pam configuration (in “/etc/pam.d”).

Mmmh, I’m not that sure. pam.d contains authentication constraints for various programs. It doesn’t launch them, actually

The login command normally makes pam calls. The configuration in “/etc/pam.d” indicates which pam modules to call. And “pam_systemd.so” is one of those pam modules, presumably the one that starts the user manager.

You may be right after all, but it doesn’t explain why systemd --user is started as root the first time I log in with my ordinary user (uid=1000)

I’m not seeing that here (with KDE). However, if I use “su” or if I “ssh root@localhost”, then a root system manager is started. Maybe “kdesu” and “sudo” have a similar effect.

No, nothing to do with su or sudo. I issue a standard graphical login with kdm, then I disconnect (logout) and reconnect with the same usual user ! First I’m root wheras I never been logged as root, then with the correct uid (1000)
Weird no ?

When I get the kdm greeting after a reboot, I open another console, and I login on it as root. Then I killall Xorg, then after xorg restarts, I make a correct login, and all the services depending on systemd work fine.

As far as I know, doing CTRL-ALT-BACKSPACE (twice) will have the same effect and with less effort.

Found something: when I get the kdm login window, I don’t login at once, but wait a few more seconds. It seems that there is maybe a hidden timeout somewhere, or a task that hasn’t been completed.

Then I login and I get a 100% working session.

The question is: how can I track this possible uncompleted task or pending timeout while the kdm windows is displayed ?

I tried systemd-analyze critical-chain, but it didn’t show up (apparent) abnormal behavior

Sounds like a problem a user in the german forum has after upgrading to 13.2 (on 2 machines, on the 3rd one it works fine… :):
On first login, the user session is not registered with logind, which causes various problems because of missing permissions with networkmanager, sound and mounting.
After logging out and logging in again, the problem is gone.

Unfortunately we haven’t found the cause yet.

A bug report has been filed here:

Can you confirm that “loginctl” doesn’t show your user session when you are logged in with the problem present?

Yes, that’s the point. I’m still investigating this issue, but I don’t understand what is happening :slight_smile:

Hi there! I’m also affected by this bug. 2 PCs with upgrade have this bug, one maschine with clean installation not.
I changes also the display manager but it doesn’t change anything. When I wait a little bit and login then after start, all is working fine.

After some findings in the german thread, I have a suspicion:
do you have ibus installed?
Try to remove it and all ibus-* subpackages, libibus can (and probably must) stay.

I’m not sure yet though whether this really is the problem…

libibus-1_0-5-1.5.8-5.5.1.x86_64, but it is required by rpmlib, libglib, libgio (rpm -q -R libibus-1_0-5-1.5.8-5.5.1.x86_64)

but that’s all.

Otherwise, as a “outstanding” package, I use postgresql-9.3 from the distro.