KDE4 menu's unreadable.Transparent vertical stripes using "Oxygen"

I just installed OpenSUSE 11.4 on a new system. Everything is plain-jane default KDE4, but there is a video problem. Driver? Hardware? KDE?

Some menu’s, most notable the right-click on the desktop, but also k-launcher and other programs have a transparent pinstripe background letting whatever is behind show through. This makes the menu unreadable.

A couple screen shots of the problem in on this photo stream:

snapshot1 | Flickr - Photo Sharing!

It is really weird, and makes the system unusable, so I am surprised I can not find any prior references. If it is a driver problem, then surely I am not the first to encounter it. That makes me suspect hardware. (I know, it’s never hardware…)

If you look close at the photos. you can see that there are pinstripes that are OK, and in between it is transparent and the dark desktop is visible. This is only for first 6-8 items in drop down menu’s, but menu bars sometimes have a pinstripe two tone effect where i think same thing is happening.

  1. The disk checks out, MD5 verified, and reinstalled with same results.
  2. I ran a memtest and memory checks out.
  3. It is consistent, in that the same menu’s have the problem in the same place for a few days now, but there are occasions when the menu is readable for an instant.
  4. Not much to try in BIOS, but no effect from changing video memory size.
  5. No other issues. Firefox menu’s are fine, and firefox browsing is fine.
  6. The system is an Intel i3-2100 with graphics on the CPU. Motherboard is an MSI-H67. Everything is new, recent manufacture (B3 stepping)

If I switch Open Gl mode from “texture from pixmap” to “shared memory” the whole display becomes unreadable, but I have no idea if that is expected or relevant.

OK, while writing this I found a workaround, but I still want to know what is happening.

If I switch System settings → Application appearance → Style → Application → Widget Style
from the default of “Oxygen” to any other option (CDE, Cleanlooks, Motif,…) the problem goes away.
Oxygen has a slick look, but I can live without that, I still wonder if it is using a graphics feature that is not working on my hardware. Or maybe just a driver problem, but this is a very common graphics system.

Any help appreciated. Thanks in advance. :stuck_out_tongue:

On 04/26/2011 01:36 PM, sadjcp wrote:
> Any help appreciated.

turn off desktop effects, that should change the symptoms and make it
easier to fix the problem, which is graphics–which is most likely
changed by following one or both of these:


then you should be able to turn desktop effects back on…

CAVEAT: http://is.gd/bpoMD
[openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8 via NNTP]
Q: What do you get if you divide the circumference of a jack-o-lantern
by its diameter?
A: Pumpkin Pi!

Hi, Actually I have the same problem. This problem is only related to oxygen theme, if you change it it goes away. Turning desktop effects on or off has no effect on the problem. I have a PC with nVidia gpu and a laptop with intel gpu and they both have this problem (64bit systems). btw, does the close-maximize-minimize buttons on your windows have similar problems when you roll your mouse over them?

I had similar problem on KDE but all those applications that had the white strip were the GTK based ones. I selected qtcurve for the GTK theme in the GTK settings section and the stripe was gone. I wonder if it is a oxygen-gtk theme problem.

I have similar problem.
I tried as you said,

  1. Turn of the effect
  2. went to the given link,
    I have lenovo G570 and I am using Suse 11.4 KDE, it has Intel Integrated HD Graphics. so I chose “Intel Graphic Hardware” sction.
    but when I try this command “Xorg -configure” it shows following errors,
    "rahul@linux-rahul:~> Xorg -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Please consult the The X.Org Foundation support
at X.Org Wiki - Home
for help. "

what should I do now.

Got the same problem on a 11.4 Opensuse fresh install with KDE

Start a new thread and provide info about your machine/hardware

Thanks sadjcp for stating the problem so that it was easy to find in a web search, and thanks for stating what I consider to be a solution, even if you don’t.

A little more detail for those new to KDE (like me):

Application Launcher
Configure Desktop
Common Appearance and Behavior
Application Appearance
Widget Style
anything but Oxygen–CleanLooks is fine

HP 4530s with Intel integrated HD3000 graphics, OpenSuse 11.4 freshly installed.