KDE4 Konqueror Super User Mode - Not!

I thought I left all those weird file permission restrictions behind in Vista UAC…

While logged in as a User, launched Super User Konqueror but it is unable to move a file from the User’s Desktop to the /tmp/ folder.

For that matter, it seems that any file which originates from a User Desktop cannot be moved to <any> folder outside the User’s file branch.

This is something that worked well in KDE 3.5 (OpenSuSE up to 10.3).

Perhaps curiously, again while in Konqueror Super User Mode I am unable to display the permissions of any folder, only file permissions. Enabling “View > Additional Information > Permissions” does not change anything (unless an application restart is required).

Is there a solution to this new problem?


Vista’s UAC is nothing extraorinary. As you have just noticed linux has the same function since a long time. Theorically, it’s very important, especially on a mutliuser system (because as root, you can pretty much destroy the whole system).

In your case, I think it’s related to a bug with kdesu. What I suggestion you to do is to use the command line:

su (to become root, or sudo su if you forget root’s password)

This way, you are sure that you can edit every folders around. You can delete your whole system, if you want (but I don’t know why will you want it).

So here is another suggestion:
There is a reason why folders other than /home/<user> is locked.

Unfortunately I later determined that the problem is more fundamental…

Instead of Su or Sudo, I logged in as root and found permissions did not change.

So, it appears to be hard coded into the file system (not KDE)… When something is created or downloaded to a User’s Home (or sub directories), that’s where the file is going to live forever (unless someone can describe a solution).

it is true I can’t do that in Super User konqueror but you can get the required result with dolphin

Alt + F2 brings up the application starter in KDE

Then type in

kdesu dolphin

It gets you your dolpin file manager with admin powers after you give it the password for root.

It doesn’t hurt to get used to dolpin, since as a file manager it is the one of the future for KDE4

I just tried that & what I get is a blank Window with Home,Network,Root,& Trash in the left pane. Along with it is this at the bottom “Could not start process Cannot talk to klauncher: The name .org.kde.klauncher was not provided any .service files.”
Guess we’ll have to wait or switch to root session.I’ll miss that capability it was an asset of KDE. I’d love to see dolphin have it.

Thx gregosmith,
Works for me.

Wonder why there isn’t a more straightforward way to find, launch and configure Dolphin (and other apps).

In the case of Dolphin, it looks like SuSE never added it as a Menu Launch item, only to the quick launch bar.

And, I don’t see a graphical way to launch the app launcher (not that I’m complaining that I can’t remember Alt-F2, but it won’t be found simply by browsing the menu items)

It worked twice.
Apparently launching Dolphin in Admin mode by way of the App Launcher (ALT-F2) is unstable.

Initially, was odd…
IIRC it might have prompted for Root password before launching app launcher, then again after specifying “kdesu dolphin”

Now, besides what Sageemta has posted, the initial root password prompt is missing, and when Dolphin launches a non-existent floppy plus the virtual CDROM is displayed but no hard drive.

Apparently is the same when launching Dolphin without Admin permissions, no hard drive is found.

Konqueror finds files/folders on hard drive without a problem.