kde4 desktop losing plasmoid placement locations

Does anyone have any ideas on this? I have kde 4.2 running on 4 machines… Love it… I have an issue with only one of my boxes where the desktop loses the locations of the desktop plasmoids after the box is restarted. Its very strange… it only happens on the one machine… I had several plasmoids and a couple of desktop icons on the desktop, and when the machine comes up from a reboot, everything is pushed to the top left edge of the desktop, and they are all overlapping each other. I use a vertical taskbar, so I have to move it out of the way to get to the plasmoids to drag them back to their proper location on the desktop… I made sure the permissions of my ~/.kde4 folder were open, thinking maybe there was some kind of privilege issue in saving the settings… but nothing changed…

Ideas anyone?

Any information would be greatly appreciated


I’ve had this problem with every KDE 4 release since 4.1. I use KDE 4.2.3 now and I still get the problem after a reboot, if my widgets are locked. If I leave them unlocked, they maintain their correct position.

I hope this works for you.

That is interesting… I typically keep the widgets locked… I have no idea why one of my machine doesnt exhibit the behavior… I will test leaving the widgets unlocked and see if it will work as a workaround… Thx!

What hardware does your problematic machine use? I’m wondering if this bug is caused by a particular hardware device. Initially, I thought it was caused by my nVidia 7600GT graphics card. I upgraded to a 9800GT, but the problem persists. Needless to say I’ve tried many different drivers.

This was an issue in the early days of kde4 but I thought even 4.1.3 didn’t have this issue now.
Way back I used to just start a new .kde4 folder. And it didn’t always work first try, it seemed pot luck if the icons would stay in place. As I recall the first login after the new folder, everything was OK, but logout and back in and oops…
So don’t think wow, it’s OK, logout and back in first.

If you are not already doing so, use kde4.2.3
I can only assume you are not, because I can’t imagine this issue would be there if you were.

KDE 4.2.3 also has this problem for me. Infact, only the KDE 4.1.3 release, that shipped with 11.1, didn’t have this problem.

I have absolutely no idea what to do about this very annoying problem.

I am in fact using KDE 4.2.3 -

OS: Linux i686
System: openSUSE 11.1 (i586)
KDE: 4.2.3 (KDE 4.2.3) “release 116”

I dont know how the video card could affect things, but someone asked about the model/version -

Vendor: NVIDIA Corporation
Model: GeForce 8400 GS/PCI/SSE2
Driver: 3.0.0 NVIDIA 180.44

I hope this info can help in some way…


Maybe our problem is caused by a plasma configuration problem. Hopefully, someone with the necessary experience will read this thread and suggest a solution.

I appear to have fixed my problem. I admit that I haven’t extensively tested my desktop…but if you want to give this a try, follow these instructions:

Navigate to /home/user/.kde4/share/config and delete plasma-appletsrc and plasmarc.

Your desktop will be reset back to defaults. You will have to build up your customizations from scratch.

This did indeed work for me… I moved the errant rc files and logged out/in … After Setting everything back the way I had it… I tested one more time - logged out and in… and VOILA!.. it appears to have fixed the issues…

Many thanks! I hope this info might help anyone else out there that might run across the same issue.

Looks like we’re both happy. Good luck!

Problem is back after reboot. **** and blast!

I cant explain it… but for whatever reason, my configuration settings seem to have stuck. If this helps debug any, I have these desktop settings:

Plain Desktop
(Desktop folder plasmoid closed)
Wallpaper - slideshow
2 desktop plasmoids displayed, both are the ‘stdin’ plasmoid - one is running top every 30 secs, the other is running ‘banner’ with no updates.
vertical taskbar on the lefthand edge.

I dont know what else could be affecting the plasmoids… I verified earlier that the session settings - ‘startup with empty session’ versus ‘startup with manually saved session’ seemed to have no bearing on the issue…


you could try:

kquitapp plasma && rm ~/.kde4/share/config/plasma* && plasma &