kde4 clipboard broken - evil magic trick

I think that the kde4.x clipboard is mishandled.

using any method of copy from a kde app causes the data to be cut instead of copied when pasted into another app (even non kde).

Non kde apps behave as expected.

open gedit and kwrite.
type K in kwrite.
Type G in gedit

highlight the G in Gedit
(select copy or use primary)
middle click or paste into kwrite.
fine - there’s a G in both editors.

Reverse, copy the K from kwrite and copy paste it into gedit.
when you go back to kwrite the K is gone!

Evil Magic.

what’s up?

Can’t wait until kde 5 or 6 when t gets to be usable again.


Hello xaos_incorporeal,

Which ones did you try?
I tried these and they all worked correctly:

Right click->Copy

And could you tell us which version of openSUSE you have?

Maybe it’s a wrong setting.
Try making a new user and look if he’s got the same problem.

Good luck!:wink:

IMO the default is set up odd. Some seem to like it.

Right click the clipboard. Configure

select separate clipboard and selection.
I also checked Ignore selection. But in any case you can configure it to how you like it.

Here’s a demonstration of how KDE4-s clipboard misbehaves, (the stands for sucks).
It’s been tested with
Mepis 8.48 kde4 desktop and FLWM
Mepis 8.5 kde4 desktop and FLWM
Open Suse 11.2 Gnome and icebox
Each of the above was demonstrated on an AMD and Intel platform.
I suspect that anywhere there’s a KDE4 app there’s this simple bug - at least.

  1. open ANY kde4 application that has text input (even konqueror, konsol, kalarm, kjots etc ) - but lets use kwrite. This will be the text source for the clipboard.

  2. open ANY other application (KDE or anything - even gterminal) - well use gedit. This will receive snippets of text from the kde source app.

3)In kwrite, enter these lines of text

a) kwrite ctrl+c
b) kwrite ctrl+x
c) kwrite shift+delete
d) kwrite just highlight me (middle click in other app)
etc …

  1. Highlight a line and use the appropriate copy technique or cut as suggested. It doesn’t seem to matter if you highlight with the keyboard or the mouse.
    Switch focus to the receiving app (alt+tab etc)
    and paste using Ctrl+V or shift+insert (but use middle click for D)

  2. Not that the new text is now entered into the receiving application (gedit).

  3. switch back to the sending app (kwrite)
    Note that the source text is gone. (this is OK for B and C but A and D are NOT CUT Commands but COPY )

  4. Repeat steps 5 and 6 until all clipboard cut, copy and paste techniques have been tried.

  5. reverse the operation by switching source and destination apps.

ie type this into gedit:

a) gedit ctrl+c
b) gedit ctrl+x
c) gedit shift+delete
d) gedit just highlight me (middle click in other app)

And you will notice that the behavior of lines A and D is correct = gedit and non kde apps ONLY SURRENDER CUT DATA.
Copied data remains in place.


  1. data is lost from the kde4 source when the app recieves focus.
  2. ctrl+z restores the data (A pain but it restores it without stealing t back from the other app).
  3. you can paste the data back -without stealing t back from the other app!
  4. (3-b really) subsequent pastes do not affect the previously selected source text.
  5. you can copy and paste within the same app (not sure about different tabs) indefinitely and the source text remains in place

Since KDE4 apps (every one of those bastards) misbehave while non KDE apps function as expected (net beans, eclipse,opera,firefox, gedit, open office etc.)

  1. A KDE shared library is the culprit [since only kde misfunctions]

  2. Seems to be specifically a lostOwnership() type problem (or whatever signal handler is used) to notify the transfer [observation 3 and 4]

  3. KDE 3.5 was perfect.

  4. KDE 4 has so many other problems one can’t help but wonder if some parts of the linux community
    A) has gone insane trying to outwow microsoft and apple desktops and are skimping basic functionality code
    B) has been infiltrated by corporate spies from M$ and @pp]e to foul base code. Imagine that-getting paid to write bad code for free.
    C) Too many out of work MS pros are boosting their resume with open source coding - thus influencing the overall library and effect.

Reduce expectations and develop patience and tolerance.
Don’t use KDE4 apps.
Back to 3.5 - oh, the pain
Wait for kde5 (or 6) - by then I’ll have to upgrade anyway
Write my own apps (not the best idea either).


Trying it with KWrite and Mousepad (Xfce editor) in KDE 4.4.2. I cannot reproduce the behaviour that you report; everything’s working fine.

Hello xaos_incorporeal,

I tried it with KDE 4.3.5 and gedit and it all worked as expected.
Have you tried to make a test user and see if that user has the same problem?
If he doesn’t have the problem it’s most likely that it’s a wrong setting in your user.

Best of luck!:wink:

I had a very similar situation using kate or kwrite, where a copy action was magically turned into a cut action.

I finally resolved this by

uninstalling scim ( chinese input method)

and then removing any kde3.5 packages
and running zypper up , zypper dup
with only kde4 repositories.

I do not know , if this will help in your case, but it’s worth a try.:stuck_out_tongue:

It’s SCIM that can do this. I managed to turn the effect on and off by installing and uninstalling SCIM. It did some other weird things too.

Thank you all-
This is the second time that SCIM scummed me.
I thought I had it disabled - there was no evidence that it was running.
I disabled it and KDE apps are working properly now.
That’s one bugaboo out of the way.

KJots is crucial to my deprecated method of coding and keeping info.



I too have experienced clipboard problems. I don’t have scim installed, but my problem with kde-4.3.5 on openSUSE 11.2 is getting it to paste the correct copy operation.

  1. Copy some text to clipboard , paste to other app works
  2. Copy some text to clipboard , paste to other app pastes text from 1), view clipboard and both copies are there. Try select correct one and paste and still get 1)
  3. Clear clipboard and start over is a pain.

This problem is in the configuration of Klipper. As default hilited text is put in the clipboard. Change it in Klipper configure. Drove me crazy until I reconfigured Klipper

Drives me crazy too! tried configure Klipper but nothing seems to have any effect.