KDE4, Bluetooth, Dolphin and Obex


in KDE 3.5 i could browse my cellphone (Nokia) directories in Konqueror with obex protocol.

now in KBluetooth4 menu (KDE 4.1/2) i don’t see such an option and Dolphin doesn’t recognize (not support?) obex protocol. is that correct or i am missing anything?

FYI, i can interchange files Box <-> Cellphone.


  • Rhaddamant,

doesn’t work yet. Keep an eye on
it has a One-Click-Install.

Use Konqueror until then.


In openSUSE 11.1 konqueror4/3 does not recognise obex too. I resorted to openSUSE 11.0 machine recently.

I just found a very simple work-around to this problem, while we wait for kbluetooth4 to get an obex kio slave. Details are at:

OBEX for dummies | Field Commander Wieers

but essentially, you just need to install obexfs (for openSuse, it seems we don’t need dkms-fuse), then mount your bluetooth device with …

obexfs -b <bluetooth address> <directory>

After doing this, you can browse and manage your device’s files with Dolphin, Konqueror, mc, or any other tool you prefer.

According to Mr. Wieers’ blog, it’s also possible to use obexautofs to automatically scan for the device, but I haven’t tried that yet.

I hope this helps others out there - if so, please spread the word.

Thank you, Thailandian!

I use KDE 3 Konqueror at the moment (with bluetooth packages from custom openSUSE 11.1 repository), but solution you have found seems to be more universal.

This OBEX KIO issue has been dragging on since the first KDE4, it’s amazing that this hasn’t been wrote or ported from 3.5 where it worked perfectly.

Is this working in Gnome?