KDE4 application search twice


now I also installed suse linux 11.1 with KDE4. It works quite well but I have an issue.

When I install software via yast I then have all results twice, if I make a search in the normal KDE menu. I had this also before but reinstalled my system. Now I have it again. I think yast calls some script that create this search results twice.

The normal menu is free from such a unnice behaivior.

I use this function quite often and would be happy, if there is any advice.


Are you saying if you use the search: It shows 2 instances of the application.?

What if you navigate to the application location, are there 2 there?


“The normal menu is free from such a unnice behaivior.”

no, if I browse, than every application is only once.

If I use the upper search field in the same menu, the results are listed twice.

Before my current configuration I installed KDE3 and KDE4 and though this was the reason. But now I only have KDE4 and it also happens.


You could try going to Menu Editor (right click menu)
Then - EDIT
Restore System Menu


thank you for this hint, but it seams not to work. Since I had an other serious problem I had to install again and again I have the same problem.

directly after installation it works well, and after the online system update everything us twice for the search application.

I could not find out, where this problem is coming from. Maybe some KDE4 update packages or the kernel?


I get 2
eg: kwrite or as in this k3b


Because I have installed kde3 and kde4

Right, and you will have .kde as well as .kde4. I would suggest this:

Hit Ctrl-Alt-F1
Login with username and password, do this:

mv .kde .kde.old

Hit Ctrl-d to get back to login prompt
Hit Ctrl-Alt-F7 to get to graphic login screen, login and see if Start Menu has changed behaviour.

Now I’m sure you are not pointing this info at me.
I like my 2 appslol!

Thank you. I also tried this several times but it does not help.
I still get everything twice.


> Thank you. I also tried this several times but it does not help.
> I still get everything twice.

from where i sit it looks like you do not get everything twice, but
instead get TWO DIFFERENT things, one for KDE3 and a different thing
for KDE4…

solution? backup all data then i’d try adding a new user and logging
into that new user in KDE4 and NEVER log into KDE3 in that new user…

if that doesn’t work i’d try to delete KDE3 in YaST…