KDE4.3+ won't mount CD/DVD: Workarounds

Since updating my openSUSE 11.2 laptop with KDE4.3 (or possibly KDE3.5) every disk I insert is not recognized by device manager, be it audio or data CD, video or data DVD.

I only noticed this problem today, as I seldom use the CD/DVD drive, so I’m not sure about the exact version of KDE4 where the problem started. I do know that I didn’t have this issue a couple months ago, probably with KDE4.2.

This problem is registered at bugzilla, in various forms of behavior, but is not considered high priority, from the reports I read, so it may still take some time to be fixed.

There has been many posts of similar problems in this forum, most still unsolved, unfortunately. Search for can’t mount dvd kde4 to see for yourself

Things I checked, based on those posts:

  1. udev rules for the drive exist (in /etc/udev/rules.d/70-persistent-cd.rules) and seem to be working OK, as device ID (pci bus ID) matches the one shown by hwinfo (or Yast’s Hardware info, if you prefer a GUI) and /dev/sr0 exists.

  2. /dev/sr0 and it’s symlinks (/dev/cdrom, /dev/dvd, etc.) exist, belong to group cdrom and have read permission assigned to everyone (rw-r–r–).

  3. Adding the user to group cdrom makes no difference, as it shouldn’t since everyone have read permission. Nor to group disk, as has been a (dirty) solution a long time ago…

  4. Testing with a new, recently created user makes no difference, so it’s not an inherited /home/.kde4 setting inconsistence.

  5. Logged once as root (just once, off-line, didn’t run any app, please don’t shoot me) and tried a data DVD and a CD. None where recognized in Dolphin’s places nor by the device notifier nor in konqueror’s My Computer kio.

  6. Updated the system trough Yast (including desktop and standard kernel) and also KDE4.4.1 to the latest 11.2 factory repo. Still nothing.

  7. Tried to mount manually, as suggested in another thread. It worked. Only tried with data CD and DVD, no audio CD or video DVD. I can access the files normally by navigating to the mount directory, but the disk is still not shown in places, device manager or my computer.

  8. Then I rebooted and, after KDE loaded, inserted a disk. Nothing.

  9. Tried konqueror’s audiocd:/ kio protocol, and it works, kind of, in that it allows me to see the audio CD contents and copy it to the HD if I want (it’s very cool, really), but I can’t play directly from the disk.

  10. Then i left the disk in the drive and rebooted. SURPRISE! The disk appears in places, device manager, etc., already mounted, and everything works as it should. KSCD plays audio, kaffeine plays video DVD, dolphin show data CD and DVD in places, etc. However, if I eject and reload the disk it goes invisible again.

So, to sum it up:

A. TO MOUNT ANY DISK: Insert disk, reboot. Only eject when you’re finished using the disk, or you’ll have to reboot again.

B. TO MOUNT A DATA DISK WITHOUT REBOOT: mount the disk manually. To mount the disk contents to the usual directory, do from a terminal (don’t type the comments inside the parenthesis:

(enter root password)
mkdir /mnt/cdrom (only do this if the mount directory doesn’t exist; off course you can give it another sensible name, avoid spaces and weird characters)
mount /dev/sr0 /mnt/cdrom (if by a very small chance your drive is assigned another device name, you’ll have to find it. Fortunately, Yast’s hardware info will show it it the CD-ROM listing details. OR you can use one of the symlinks, like /dev/cdrom, /dev/dvd, etc.)

You can close the terminal now if you wish.

To eject the drive you have to unmount it. Again from a terminal type:

(enter root password)
umount /mnt/cdrom (you can also use the device name here, as in umount /dev/sr0 OR umount /dev/cdrom OR /dev/dvd, OR…)

C. TO ACCESS AN AUDIO DISK WITHOUT REBOOT: use konqueror’s audiocd:/ protocol, i.e., insert the disk in the drive and type audiocd:/ in the address bar in konqueror. I suppose it also works in dophin, but I’m not sure.

This will allow you to copy the music but not to play it, as far as I tested.

D. TO ACCESS A VIDEO DVD: No idea whatsoever…

Well, sorry for the long post, I hope it may help someone.

Many thanks

This appears to be fixed in 4.4

Not for everyone, apparently. See item 6.

Now I’m seeing the same behaviour in a desktop running 11.3/KDE4.5 with a much used Pioneer DVDWriter. It did work right after installation a couple of times. I’m starting to thing that the problem may be hardware related. Maybe.

Today I tried the same laptop with 11.2+gnome and KDE4.5.
And in gnome the DVD work as it should (!!!), so it’s definitely a KDE issue.
Now I only have to find why…

Hi brunomcl. Maybe consider upgrading to KDE4.6.X (It uses udisks, so might play nicer with your hardware).

Thx deano_ferrari.

I tried 11.2/4.6, but had issues with something I don’t recall right now, and ended up downgrading to 11,2/4.5. But I did upgrade the desktop PC to 11.3/4.6, so I’ll test it when I have some time.

I don’t really need to solve this as I seldom use this laptop, even less it’s DVD, and it’s so old it’s getting flakey at the corners :).

But I have seen a number of not-so-old posts of people with similar problems, so I thought of giving some feedback here.

I tried the same hardware, but updated to KDE4.6.2 a few weeks ago. Worked OK with DVD (movie) and DVD-R data disk.

So it seem the problem was related to udev/udisks/KDE4.5 or 4.6.0.

And, as what is probably my last post in this thread, yesterday I installed 11.4/KDE6.0 in a spare HD in the laptop, and guess what: the DVD drive is working as it should, with KDE recognizing data DVDs, Video DVDs, CDROMs and such (didn’t test audioCDs)

That is great news :slight_smile: