KDE4.3.* Upgrade - HowTo

No worries. Lakeland eh!
Nice: My Fl. zip: 34652

Yes not far from me at all. Nice up there.

I’m already on 4.3 at my main (home) machine but the work computer is still running Gnome. What’s the best way to migrate from Gnome? Install 4.1 first from the OpenSUSE DVD or OSS repo and then upgrade as above? One-click install of 4.3? Enable the Factory repos for a fresh install?

I have never used gnome in suse.
I would do this.
Add the kde4 Factory repo’s I list (Check your priorities!!)

Yast Software Management
Patterns
Check kde4-desktop, kde4-base
See what happens here and work thru accordingly. I’m about for a couple of hours or so.

Thanks, but I’m at home now and won’t be able to do it until back at work in the morning (see my location!). Will follow your suggestion and report back.

Some cruel twist of fate meant that I had to actually do some work yesterday so I only got round to it today. Got 4.1.3 at the first attempt as I forgot to change the priority of the Update repository, but a quick change to 99 and an unconditional update of the KDE package group did the trick. Now have a shiny new 4.3 desktop at work, and with the necessary tweaking of the desktop even more reason not to do any actual work!
Thanks for your help, that was easier than expected.

Good to hear and thanks for letting us know how it went.

All’s not well though. I’m having regular freezes (everything stops except the mouse movement, and a hard reset is the only option) which I have now tracked down (I think) to 3d acceleration, as it seems to be okay when I disable the desktop effects. My video is Intel 915G, and I’ll go off and try Xrender instead of OpenGL in a minute once I’m satisfied that everything else works with desktop effects disabled.
Any suggestions gratefully received: change Intel video driver?

Can’t enable Xrender effects, system insists on OpenGL.

I’m using OpenGL on my Intel
Works brilliantly!

Well so does mine for a few minutes before freezing… :’(

… and, of course, I have no problems running Gnome with Compiz compositing, so it seems an issue between Intel and KDE.

But I’m using kwin
http://thumbnails17.imagebam.com/4525/ad13e145246764.gif](http://www.imagebam.com/image/ad13e145246764/)
Are you?

Yes, in KDE4. I was talking about Compiz in Gnome. Perhaps I should try 4.3 with Compiz rather than Kwin, just to see if it’s a problem specific to Kwin?
Can’t do anything until Monday anyway as I won’t be back at work till then…

Ah, now I see what you’re suggesting! I haven’t checked the dialog in your screenshot yet, do you think I might have Compiz running? Surely not, isn’t Kwin the default in KDE4? Could Compiz be “lingering around” in some fashion from Gnome???

kwin uses Compiz. kwin is the window manager. I was thinking maybe you had done a specific install of Compiz with it’s window manager and themes from Emerald?
Confusing isn’t it.
Compiz is installed with kde4, but if you want all the fanfare and whiz bang of Emerald you have to add some stuff.
I would check that you have kwin set as the window manager.

Didn’t know that Kwin used Compiz. Anyway, my installation of KDE 4.3 was a “virgin” one, no changes to the window manager from default so I assume it’s Kwin unless the previous installation of Gnome messed things up. Will check on Monday…

OK, this is what I found:

KDE 4.3 with Kwin and various effects (cube etc) enabled: no go (freezes after a short time, as described above).

KDE 4.3 with desktop effects disabled: fine though lacking eye candy.

KDE 4.3 with Compiz: fine, no problems so far.

This seems to suggest that the problem lies between Kwin and the Intel video, no?

Possibly. You would need to see the error logs and maybe xsession-errors to see if there we clues there.

Though, as I have Intel with kwin/compiz effects and it’s never been better…

I’ll keep plugging away as I really prefer Kwin over Compiz: everything in one place for starters, no fiddling around with Emerald etc.