KDE4.2: Zypper update made a mess.

Updated the OS yesterday and now my desktop is a mess.

Many of the KDE windows have now ugly shady like black lines round icons and borders. Further more all my hotkeys <alt + whatwever> no longer works also dolphin is no longer able to use any protocols such as fish or smb. I also experience some windows all the sudden not to accept any input from the keyboard, mouse clicking is fine but when using the keyboard nothing happens.

Some screenshots:


openSUSE 11.1 x64, KDE4.2, RadeonHD

Anyone experienced the same ? Not sure what to do now, should one wait for an update or file a Bugzilla ?


Brgds Jonas

Have you tried renaming your .kde4 folder to “.kde4-old”? Try that and restart KDE. It may just be some sort of settings conflict. If making that change fixes things, then you can work on narrowing down which settings were the problem.

Not sure why your keyboard is acting up…does it work consistently on the terminal (ctrl-alt-f1)?

It appears that your widget style switched from “Oxygen” to “Windows” for some reason.

Try going to systemsettings -> Appearance -> Style and see if you can’t select Oxygen widget style.

Another thing. Try zypper dup instead, or use YaST like this:

Often with these repos, it can happen that packages which are actually newer appear to yast to be older - hence ‘zypper update’ is not completely reliable.

Also post the output of ‘zypper lr -up’ please, so we can see if your repos are as they should be.

We might be on to something here… Oxygen is not part of the list. The only options I have are:

  • CDE
  • Cleanlooks
  • Motif
  • Plastique
  • Windows

It was set to CDE, changing it to Cleanlooks does make some improvements. Are the hotkeys also effected by these styles ?

Brgds Jonas

I ran a “zypper dup” and that indeed updated some kde-packages. Now oxygen have reappeared in the style-list also the other problems with hotkeys and dolphin seem to be gone!

Thank you so much for the help!

Brgds Jonas