KDE4.1 Power Mangement, always suspending...

Two days I go, I decided to try KDE4.1 instead of the old trusted KDE3.5, however… I’ve some strange behavoir which makes my notebook unusable.

I’ve a notebook (Dell Latitude D830). Powermanagement locks my session again and again. Sometimes I notice a message like

Power Management

The computer will be suspended to RAM in 10 seconds. Click here to block the process

The truth is, that the notebook even suspends when in charger!

> Why does this all happen?
> Is there another PowerManagement available?
> Is it KDE4.1 or is it OpenSuse itself?

I hope someone can help me :slight_smile:


PS. This is another topic on linuxquestions, it is not mine, seems te be the same problem.

> Why does this all happen?
> Is there another PowerManagement available?
> Is it KDE4.1 or is it OpenSuse itself?

Good questions! From a console, do

ps -A |grep power

For reference I get:

dean@linux:~> ps -A |grep power
2633 ? 00:00:00 powersaved
3140 ? 00:00:08 kpowersave

We’ll have a look at your output. I’m still using kpowersave (front-end) and powersaved daemon (as with KDE 3).

You may have PowerDevil running which can cause problems for some users. (I understand it works better in the KDE 4.2.x branch). I would consider upgrading to KDE 4.2.1 anyway, as it is a much improved version from 4.1.

You may have to make a choice here:
As I recall there is a conflict between Powersave kde3 and Powerdevil kde4. As has already been touched on.
Try uninstalling Powersave. But I’m not sure Powerdevil will manage kde3, so you may be without in kde3.

Another option might be not to start powersave auto, but only as required in kde3.

This short thread may also be of interest to you. (Supports caf4926’s post).

Truth is…

linux-zrax:/home/remco # ps -A |grep power

returns no output. There’s nothing in the list so far which refers to power.

When I look up which powerthings are installed I get this list:

linux-zrax:/home/remco # zypper se power
Loading repository data...
Reading installed packages...

S | Name                            | Summary                                                           | Type
  | cairo-dock-powermanager         | That package provides a powermanager plugins                      | package
  | cmpi-pywbem-power-management    | Power Management Providers                                        | package
  | gnome-applets-inhibit-powersave | A GNOME panel applet to disable and reenable power saving         | package
  | gnome-power-manager             | Power Management for GNOME                                        | package
  | gnome-power-manager-lang        | Power Management for GNOME                                        | package
  | kpowersave                      | KDE Frontend for Battery Monitoring, Suspend, CPU Freq and Gene-> | package
  | kpowersave-lang                 | KDE Frontend for Battery Monitoring, Suspend, CPU Freq and Gene-> | package
i | powerdevil                      | KDE Power Management                                              | package
  | powerdevil                      | KDE Power Management                                              | srcpackage
i | powerdevil                      | powerdevil: Prevent high CPU usage of X servermanagement          | patch
  | powerdevil-lang                 | Languages for package powerdevil                                  | package
  | powermanga                      | Ein arkade 2D Ballerspiel                                         | package
  | powermanga                      | Ein arkade 2D Ballerspiel                                         | srcpackage
  | powerprefs                      | Configuration frontend for the PBButtons daemon                   | package
  | powertop                        | PowerTOP is a Linux Tool to Find out What is Using Power on a L-> | package
  | texlive-ppower4                 | Post Process presentations in PDF                                 | package
  | yast2-power-management          | YaST2 - Power Management Configuration                            | package

kpowersave isn’t isntalled, and I can not find any powerprocesses running, however there’s a widget on my plasma desktop. Removing that widget doens’t effect anything. Also powerdevil is listed twice… Is that a problem?

Maybe I’ll try updating to KDE4.2 this evening.

Yes, here’s hoping the upgrade will fix the problem for you.

Just as an aside, here is a link to an interesting interview with PowerDevil developer, Dario Freddi.

I’ve updated my KDE to version 4.2

remco@linux-zrax:~> kded4 --version
Qt: 4.4.3
KDE: 4.2.1 (KDE 4.2.1) "release 106"
KDE Daemon: $Id: kded.cpp 918838 2009-01-30 20:28:25Z dfaure $

However… I’ve still the same problem. When my notebook is connected to the adapter, the screen is locked every time. When I’m running on battery the system goes to standby, even at 90%.

Any suggestions?

It’s likely your settings are all messed up:
try deleting:

logout and back in
run thru your settings again if necessary

Wow… Thanks.
That fixed it. I had this issue two times (installed opensuse 2 times on my notebook). I did not change any of the powersettingsvalues myself. Maybe there is a OpenSuse default value not correctly set.

However, this problem is solved. Thanks for the comment :slight_smile:

If you mean my advice fixed it - Great.
Well done!