KDE4.1 + Compiz doesn't work in 11.1

I installed 11.1 the day it got released upgrading my existing 11.0 installation.
I’m a fan of Compiz and it worked fine in 11.0 with KDE4.1 as desktop manager.

After upgrade, it doesn’t work at all.

I had some troubles with nVidia drivers, but now they are fine (I use a 9700M GT, which requires manual installation), and Xgl is enabled since I can use glxgears fine.

When I go into KDE’s Window Manager settings I can’t enable Compiz: it says it failed to start.

All of my packages are up to date with lastest version, and I have set up proper repositories for Xgl and Compiz.

Can somebody help me step by step solving my problem? Thank you very much.

You may wish to try adding the repositories that are maintained by Cyborg and install his version of Compiz without the Nomad patch.


Could you please give me the URL of that repository? I added the X11:XGL repository at Index of /repositories/X11:/XGL/openSUSE_11.1. Is that correct?

Sorry, I don’t understand. Why do you need compiz? Almost all effects already exists in new KWin… cube, wobbly windows, etc etc.

For me the lack of customisation over keyboard shortcuts and mouse clicks on desktop edge in KWin was why I set up compiz.

I thought the same at first, but I managed to put shortcuts as I like and also screen edges the same as in compiz.
Buzz is that I had to do it manually from “configure desktop” -> “keyboard shortcuts”, but OK, no big deal. Everything works the same.

I have a remark in KDE4 that settings are bit confusing, but at least all are there.

Add this repo to your YaST software repositories, install the Compiz related items that are updated from it.
Index of /repositories/home:/cyberorg/openSUSE_11.1

Didn’t work :frowning:
Anyway since I enabled Xrender on Kwin the whole KDE goes worse. It won’t let me re-enable OpenGL rendering, but I’m 100% sure Xgl works fine.

What can I try then?

Sorry, I don’t mean to be boring, but did you try without compiz, XGL and emerald and whatever else. Just plain KWin at 4.1 works OK. I had to remove all startup things for compiz and emerald to get my beloved cube work as I wish.

You might want to check your /etc/X11/xorg.conf and see if it has compositing turned on.

The last section should be something like:

Section “Extensions”
Option “Composite” “Enable”
End Section

Composite is enabled. When I try to enable Compiz from KDE’s desktop configuration it still says Compiz failed to start and goes back to Kwin.
I tried all the solutions proposed in this topic, and removed Compiz repository from YaST.

Kwin effects, however, work very slow, and I see no trace of the cube even if enabled. Glxgears still reports thousands of FPSs (3144)