KDE4.1 beta fails on 2nd Login, OK 1st time?

I recently upgraded kde4 to the factory repo for 11

I had tried several times before, but plasma crashed at every attempt to login.
This time I renamed .kde4 to .kde4old - to create a new.kde4 at login
It worked!
But logout and try to log back in
I get a blank grey screen. No error seen.

If I delete the newly formed .kde4 folder and try again - It is fine. But logout and back in - the same grey screen.

Strange. Anyone any ideas please?

Ok, I’m using the latest kde4 factory with no issues. You may want to update your kde4 packages.

I still see this behavior, even now that KDE4.1 is ‘official’.

It happens on only ONE of my two machines…the nvidia-based
one and NOT on the ati-based one, and I’ve determined that this is
signficant! *

Workaround: If you can live without ‘nvidia’ driver, at run-level 3, try switching to
‘vesa’ driver via:
sax2 -r -m 0=vesa

and the problem goes away…I can then logout/in between 3.x and 4.1 ok.*

I am Nvidia, but all is working now. It just came ok about 2 weeks ago.

Upgraded my nvidia driver to a newer version, released just
today (30-July-2008), and that FIXED IT!