KDE

I attempted to upgrade KDE 4.7.2 to KDE 4.8.3 by using the yast repository manager.

There is a good chance I did not let the installer finish the install before I rebooted and, on reboot, I was asked for a login which I provided but was rejected.

I tried to boot up with the installation DVD but again, I was asked for my login wiich was rejected.
My question is, how can I roll back to KDE 4.7.3 or boot up on KDE 4.8.3 or just get around the login?

There is a brute force way to fix this and, the way of the penguin, I prefer to do this the way of the Penguin .

System;
KDE Development Platform 4.7.2 (4.7.2) "release 5
OS: Linux 3.1.10-1.9-desktop x86_64
Current user: bilbo@linux-y8y3
System: openSUSE 12.1 (x86_64)
KDE: 4.7.2 (4.7.2) “release 5”
AMD Phenom™ II X6 1090T Processor

Can you reboot and when you get to the graphical login then simply hit CTRL+ALT+F2 (CTRL+ALT+F7 takes you back) and then try logging in as root or your normal user account? If so can you from there try using zypper to do a proper update again?

If you can’t this might help too? SDB:Recover root password - openSUSE

Good luck!

Thank you for your time to reply - I will try as you suggest

ok, that put me into a login screen and I cannot log in because the system doesn’t recognize me,
I should not have to login, there IS no login, only a root password.

Brute force is starting to look like the only way

IME openSUSE always aks for the login first and then the password. I have yet to see a login screen (graphical? text?) that just asks for the root password, without at least showing the login name. If this was windows I’d say it was a virus…

Anyway, are you sure you have the correct password? Caps Lock is off? Password has non-ascii characters not passed correctly by the kbd because it’s not correctly initialized at this stage? Just guessing.

Reboot
At the grub menu press Backspace
Like shown here: https://dl.dropbox.com/u/10573557/YaST%20level3/1%20Initial%20Boot.png

Then just type the number 3
https://dl.dropbox.com/u/10573557/YaST%20level3/2%20Edit%20the%20Boot%20line.png

Hit enter

Eventually you will arrive at a text login
type your username, hit enter
type your password, hit enter

Now type:
su -
hit enter

Now type:
your root password

Now type:
zypper ref
(this assumes you are connected to the internet by wire)

Now type:
zypper dup

(y) to agree to the upgrade

Wait for it to run

Then type:
reboot

Thank you for your time but it is too late - brute force won the day.
I stripped my hard drive and started over

I am not tied to the internet via wire.
I am wireless.

I just tried again to install kde 4.8.3 with exactly the same results.

A guide to upgrading kde is here
KDE 4.8> for openSUSE 12.1 - Blogs - openSUSE Forums

In the login screen, click the Sessions option, select KDE Plasma Workspace. Then login. Please let know if that helped.

I deleted that installation/partition and did another fresh install.

I ended up reading KDE 4.8> for openSUSE 12.1 - Blogs - openSUSE Forums and got KDE 4.8 correctly.

What was I doing wrong, I have no idea as I didn’t do anything any differently this time than I did the other two attempts <shakes head>

Good to hear you made some progress

Thank you - I would have preferred I discovered what I did incorrectly and had learned something out of all of that.