KDE - X GUI hangs - no auto-refresh


I am experiencing a very annoying issue : several times a day my display hangs : no more refresh of any windows.
The only solution is to restart X (whether ctl+alt+backspace or init 3->5…)

Actually I’d rather say that X is still working, but it is not automatically refreshed anymore.
The window content is only refreshed when it gains focus. To refresh my window again, I have to switch to another window and switch back to my window. Then its content is updated… once. I have to toggle focus again for next refresh.

Let’s give an example : Konsole. When the issue is happening, no more refresh of Konsole content. But still the application is active. I can type any command, and execute it. Of course, I have to toggle focus in/off to watch results…

I dont have the single idea what is the faulty component : issue with graphic card drivers ? Plasma thing ? kdm ?

At least I would be happier if someone could tell me which process(es) I should kill/restart to solve my issue, instead of restart entire X environment (and loose all my running tasks… It happens I have to wait till an important task is performed before restarting X. So many minutes (if not hours) to do the toggle focus game… >:( ).

I am running OpenSuSE 11.4 x64 and KDE 4.7.0.
I have enabled desktop effetcts, and especially Desktop Cube Animation (and btw, the Animation is still working fine, which is another way for me to refresh the whole desktop content…).
I have QuadCore Xeon CPU, 3GB RAM and nVidia Quadro NVS 280 PCI-E/Quadro FX 330. With 173.14.30 nVidia drivers (any further release would ignore my GPU model…).

Thank you for your support !

Hard to tell what is happening for what you’ve described without actually seeing it…

But I seem to remember a very long ago what you’ve described was related to power management issues, ie. If your machine “goes to sleep” then the display can freeze.

A Hail Mary recommendation might be to take a look at your power settings, particularly if you’re running on a laptop that’s not plugged into an external power source. Set to always run the “Performance” profile, never running any of the power saving features.

Or, just keep your laptop plugged in, hardly ever run on battery alone.