kde wont start w/o monitor plugged in

hey,

i want to remote control my computer from another computer using vnc. meaning the computer just sits there on its own, nothing but a lan cable plugged in and i remote control it. strangely when i start the computer without a monitor plugged in it stops at the terminal login screen without starting a kde session. how can i get around this ?

thanks for help

Hi There

Is your default runlevel 3, or 5? If it is 3, the system will not boot into a graphical desktop environment.

check in YaST → Runlevel → Default runlevel

you say, when the monitor is NOT plugged in you are prompted with a login screen. I take it you are plugging in the monitor AFTER the computer boots to see what it is doing?

If you cold boot the computer (i.e power off then power on) with the monitor plugged in, can you get into KDE?

you can still run kde in a vnc server even if you only see a “login” screen on the console.

VNC works in two different ways (with two different programs)

what is it you are trying to accomplish?
either
A: you are somewhere other than in front of your computer. You want to remote in and use a graphical desktop environment. no one can see what is going on while you are controlling it. This desktop would have your personal settings but would be a new session.

B: you are somewhere other than in front of your computer. Before you left, you opened a text document and web browser. You want to remote in and continue right from where you left off. When you initiate the connection, you would see the programs you left open, and anyone sitting in front of the computer (your computer at home) would see the mouse move, letters appear as you type them, etc.

hey,

thanks for your reply

what i want to do more tends to A) …
we have about 10 computers in our server room that i need to monitor … we used a kvm switch first but thats clunky if you could just use vnc to monitor them.

i tried to mess around with the runlevel thing but i got stuck … i opened ‘system services (runlevel)’ on yast but kde wasnt in the list of services to choose from.

so ?? now what :slight_smile:

Hi
If you have that many to monitor, you should be looking at Nagios or
similar to monitor. Else look at using freenx or similar rather than
vnc to cut down on the overhead.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 13:27, 2 users, load average: 0.47, 0.32, 0.40
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.29

ok cool ill check on that but it doesnt really solve my problems with kde stat wont start when i start the computer… :frowning: