KDE Wayland seems broken

I updated a virtual machine from 20220519 to 20220524. Plasma Wayland had been working okay, although not as well as X11. But, after the update, the screen was full of artifacts and the session was near unusable. I rebooted, then went to Plasma-X11 which is still fine.

I tried another VM which currently has Tumbleweed 20220523. I normally use X11 there. So I tried a login to Plasma-Wayland. And again, the screen was full of artifacts and the session was almost unusable.

Something must have broken Wayland in a recent update.

This is mostly just a query as to whether others are having problems. The KVM host uses Intel graphics (Ivy Bridge).

Looks OK in QEMU with Gtk console and virgl. KDE display was broken immediately after online update, but OK after reboot.

I call qemu directly without using any high level management like libvirt.

I am using libvirt.

I updated while logged into Icewm, then reboot. And that’s when it started misbehaving.

However, Wayland is fine for a direct login on my desktop computer. It is only with KVM sessions that things go awry.