KDE Wallet Service

“openSUSE Leap 42.1 (x86_64)”
Linux linux-b5px 4.1.15-8-default #1 SMP PREEMPT Wed Jan 20 16:41:00 UTC 2016 (0e3b3ab) x86_64 x86_64 x86_64 GNU/Linux

When starting the plasma 5, I get error:

Error opening the wallet ‘kdewallet’. Please try again. (Error code -9: Read error -possibly incorrect password). However I’m entering password right. I also enter password to another ‘old’ style dialog and it accepts it and old applications work. But new plasma 5 one is not.

How did you get there?

Specifically, did you upgrade kwallet from opensuse 13.2. Or did you downgrade from Tumbleweed?

As far as I know, upgrade from Tumbleweed should work for the KDE4 wallet, but you should be prompted for a new password for the new plasma 5 wallet. Downgrading from Tumbleweed doesn’t work, particularly if you used GPG encryption for kwallet on Tumbleweed, since Leap does not appear to support that.

You can delete the wallet files – best done while not logged into the plasma 5 desktop (you could login to Icewm for that). That would allow you to start over. But you would lose what is saved in the wallet.

Thank you very much for fast responce.
I upgraded kwallet from opensuse 13.2. KDE wallet migration service also requests password but fails with the same error.
Can I export old wallet unencrypted and import it to the new one?

Thanks for the alert!
I’ve checked this Leap 42.1 system which was upgraded from 13.2 and found:

  • kwalletmanager:

zypper info --requires kwalletmanager reveals that this package requires the kdebase4-runtime and kwalletmanager5.

In other words, it’s the Plasma KDE4 KWallet manager . . .
I suggest that it should be simply removed.
[HR][/HR]Apart from WLAN access and KMail ISP server passwords there isn’t too much in this machine’s wallet:I managed to get by by simply deleting the wallet and then recreating it.

But, I thoroughly recommend exporting everything you can think of before upgrading from 13.2 to Leap 42.1; and, before performing the upgrade take a break and preferably sleep overnight as well and then, before performing the upgrade, export everything you forgot to export the day before.
[HR][/HR]Kontact/KMail is also proving to be an issue: the upgrade left the Plasma KDE4 version active and didn’t automatically (auto-magically?) offer the Plasma 5 version.

I did that (successfully) a while ago.

However, I imported the 13.2 wallet into the kde4 wallet (using kwalletmanager). Then I allowed that to migrate into the plasma 5 wallet. I later installed “kwalletmanager5” (which uninstalled kwalletmanager) so that I could configure the Plasma 5 wallet.

Just a note: since the last KDE Applications update (released for Leap and Tumbleweed last week) it is now possible to have both (kwalletmanager and kwalletmanager5) installed at the same time, and also both should be installed by default now on Leap 42.1, for Tumbleweed the installation patterns have been changed to (only) install kwalletmanager5 some time ago (but you can install the KDE4 kwalletmanager in addition manually now).

I strongly disagree.
You need it to manage the KDE4 wallet, that is used by KDE4 applications (kdepim4 e.g., or konqueror).

As long as not all applications are ported to KF5 (or kwallet5 is changed to also support KDE4 applications and “replace” kwallet4), we should not remove it.

As I wrote in my previous post, it doesn’t get installed by default on Tumbleweed any more though, and therefore won’t be in Leap 42.2 either (unless this is going to be changed again… :wink: ).


I knew there was a bug report on this that was marked as fixed. But I didn’t notice that the fix had made it to the repos.

I have now reinstalled kwalletmanager (on Leap), though I’m not sure that I’ll actually need it.

Thank you wolfi323. I’ve reinstalled it and am currently having fun getting the Plasma Menu sorted out – need to distinguish between the Plasma 5 KDE Password Manager and the Plasma KDE4 version – they were indistinguishable from one another when searching.
[HR][/HR]I’ve also finally got the Plasma 5 Kontact almost up and running – it took a while to realise that I had the KDE4 Password Manager open but, the KMail passwords had been migrated to the Plasma 5 Password Manager (somehow - unnoticed). :frowning:

Yes, I know. They have the same name.

But you can open kwalletmanager5 in “Configure Desktop” (systemsettings5) too.

I’ve also finally got the Plasma 5 Kontact almost up and running – it took a while to realise that I had the KDE4 Password Manager open but, the KMail passwords had been migrated to the Plasma 5 Password Manager (somehow - unnoticed). :frowning:

As has been mentioned already, kwallet5 migrates/imports the KDE4 wallet on first start.

I installed kwalletmanager but that does not changed anything. Moreover, I can’t find kwalletmanager in plasma menu.

Run it from the command line.

It is in “System”.
But you can also just run it in Konsole (as nrickert wrote) or KRunner (the Alt+F2 run dialog).
If you want to use the KF5 version (for the KF5 wallet), run kwalletmanager5, or enter “Configure Desktop” (systemsettings5)->“Account Details”.

Regarding your problem: try to delete the folder ~/.local/share/kwalletd/. kwallet5 will then migrate the KDE4 wallet again on the next start, and it should have the same password as the KDE4 wallet.

Thank you very much. That helped. However, GPG encyption key is not working, ,so selected blowfish. Kwallet requested new password and migrated successfully.

After the recent updates, GPG encryption is working for me.

So I used “kwalletmanager5” to save the kwallet content to a file (“export as XML”). I saved to my ecryptfs private directory, so it was really encrypted on disk.

I then logged out of KDE and into Icewm. I deleted the directory “.local/share/kwalletd” – actually, I renamed it to “kwalletd.old” for safety.

Then I logged into KDE again, and recreated kwallet, this time using GPG encryption. Then I imported from the saved XML file. And then I used “shred -u” to delete that file.

So I now have both the new kdewallet5 and the old kde4 wallet using GPG encryption with the same key. It’s great. I am only prompted once per session. When the first of those wallets is opened (usually the kde5 version), gpg-agent gets a copy of the gpg private key. And the second wallet can then open without my being prompted again.

Thank you very much. That worked for me too.