KDE v4.2 won't logout

OpenSUSE 11.1 - KDE 4.2

Can login to KDE 4.2, use it fine but when I attempt to logoff, it won’t. Screen remains the same as before trying to logoff. Tried from root, same result. Only way out is shutdown -r now.

Gnome works w/no logoff problems.

Looks like you are missing something how did you install? Did you check th media?

Installed from OpenSUSE store bought media. And btw, forgot to mention, this worked fine for a long time. Now it doesn’t. Perhaps an update? Which one?

I can live with this, but it is annoying and I think hard to troubleshoot.

Without being able to provide any help actually trounleshooting this, I’d recommend to upgrade to KDE4.3.5.

Currently running KDE 4.4.0 (release 222)

Been that way for awhile I think - when logout worked and now, when it doesn’t.

Ooops. Just noticed I mentioned KDE 4.2 above. Should have been 4.4. Sorry for the confusion.

Have you tried to delete de .kde and .kde4 folder in your /home/user ? Because then KDE made it new for you.Perhaps this can solve your problem.

It’s a known bug https://bugs.kde.org/show_bug.cgi?id=228005.
Try to disable system logout sound on system notification.