KDE Update Error At Boot: CURL/Chrome DEV

The following error is shown at boot time in notifications (all Kernels). Permanently for logout/login. Not present in Gnome.

Download (curl) error for 'http://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/repomd.xml':Error code: Connection failedError message: Could not resolve host: dl.google.comError message: 

Is there a way to get rid of it?

Google Chrome Dev RPM Package
Version 75.0.3753.4 (Official Build) dev (64-bit)

uname -a
Linux linux-9fd4 5.1.0-rc3-1.g7474ec2-vanilla #1 SMP Mon Apr 1 05:43:52 UTC 2019 (7474ec2) x86_64 x86_64 x86_64 GNU/Linux

rpm -qa | grep -i kernel
kernel-syms-5.0.5-1.2.x86_64
kernel-source-5.0.5-1.2.noarch
kernel-firmware-20190312-253.1.noarch
kernel-syms-5.0.3-1.2.x86_64
kernel-devel-5.0.5-1.2.noarch
kernel-default-5.0.5-1.2.x86_64
kernel-devel-5.0.3-1.2.noarch
kernel-vanilla-5.1.rc3-1.1.g7474ec2.x86_64
patterns-devel-base-devel_kernel-20170319-8.2.x86_64
kernel-default-devel-5.0.3-1.2.x86_64
kernel-source-5.0.3-1.2.noarch
kernel-default-devel-5.0.5-1.2.x86_64
kernel-macros-5.1.rc3-1.1.g7474ec2.noarch
kernel-default-5.0.3-1.2.x86_64

The error message includes:

Could not resolve host: dl.google.com

That looks like a temporary DNS failure. Maybe wait a while, then try again.

I checked here with

host dl.google.com

and it seems to resolve.

Which notifications?

Do you mean with "Permanently for login/logout that it is shown before someone logs in? And again, wher eis it shown then?

To me it looks as if some software is contacting a software repo at dl.google.com. But it is strange that that happens before any login.

And the message says that dl.google.com can not be resolved. In my system it does;

henk@boven:~> host dl.google.com
dl.google.com is an alias for dl.l.google.com.
dl.l.google.com has address 172.217.17.78
dl.l.google.com has IPv6 address 2a00:1450:400e:805::200e
henk@boven:~> 

This either find out why some tool is contactingthe repo, or why it can not be resolved (try yourself e.g.), or remove the repo from your repo list if you do not need it.

Just a few suggestions.

My bet:

  • You run KDE, and use a WiFi connection.
  • The message is coming from the updater applet.

Cause:

  • The packagekit updater applet tries to connect to the repos before the actual connection has been established.

If this is the case, set the connection to be used by all users, and set the passphrase to be stored unencrypted. That way the connection will be started earlier, before the packagekit applet starts.

Thanks for replying. Indeed, we rely on WIFI to reach the internet. It was all ready set to unencrypted, but not for all users. Didn’t make it, the message still there at boot or for logout.

Hmm. Here the message refers to Chrome stable repo, but it’s not in use. In the apt-get school, we reach source list that way, but here it opens an empty file:

leafpad /etc/apt/sources.list

How to edit the source list in Suse? Surprisingly, searching Dolphin returns no result.

host dl.google.com
dl.google.com is an alias for dl.l.google.com.
dl.l.google.com has address 172.217.13.206
dl.l.google.com has IPv6 address 2607:f8b0:4020:804::200e

Can you please try to explain this without doubt?

Does this happen

  • at boot;
  • at login;
  • at logout?

or at more then one.
I hope you understand that boot is NOT login (also they may follow each other quickly).

Please do not tell alone, but show.
For showing your repos and if they are “in use” (we call this probably “enabled”), post

zypper lr -d

And it is useless to talk about how apt does things to me, because I have no experience with it at all.

You did not answer my question about what “notifications” mean, but if that are the Notifications popping up from your KDE panel, then that has nothing to do with boot and also it has nothing to do with the kernel.

Then I assume that Knuprpht is correct and that you have the Update Applet active and that it starts reading from repos before your network is running.

To graphically edit your repos: YaST > Software > Repositories. Or, check /etc/zypp/repos.d

Got it now!

If apt-get means nothing to you, the zypper immersion takes time and efforts. It is not cosmic, just a little different. The message is shown at boot in the notification panel. When logout and login again, the panel shows the message. Disabling Chrome repo and auto refresh removes the message instantly. As seen in Software repo, the chrome Dev URL is the panel one. It refers to the stable release, but I guess it is a unique url for all versions.

The solution creates another issue, I will have to check the Google Dev website to know if there is a new version or re-enable it. No big deal because the message was removed. For those who like notifications, KDE is paradise. For those who prefer a notification-free DE, some adjustments must be made.

Thanks for help.

zypper lr -d
# | Alias                  | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                             | Service
--+------------------------+-----------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------+--------
1 | google-chrome-unstable | google-chrome-unstable      | No      | ----      | ----    |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                             |        
2 | kernel-repo            | kernel-repo                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/HEAD/standard/                |        
3 | openSUSE-20190327-0    | openSUSE-20190327-0         | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-Verbatim_TUFF_N_TINY_07073400D6443647-0:0-part1 |        
4 | repo-debug             | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                         |        
5 | repo-non-oss           | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                           |        
6 | repo-oss               | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                               |        
7 | repo-source            | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                        |        
8 | repo-update            | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/     

Knowing that WIFI is more robust in KDE, we switch to it today. There is a WIFI bug in Gnome. We loose the signal for a fraction of a second every 10-20 seconds (last 2 days with the same ISO). The side effect returns a video glitch each time. The first 10 minutes of a live streaming @6600Kbps are enough to tell the bug is real in Gnome and not present in KDE.

This is not related to the message you were seeing. But I recommend that you disable repo 3 in that list (presumably the install media that you used)

If there is something that you want to install from there, then install that first then disable.

The problem with leaving it enabled, is that it will block some updates, especially as Tumbleweed advances beyond the level of that install media.

That is probably related to KDE/Plasma5 on Xorg, GNOME by default on Wayland. So I suspect rather a bug in Wayland, than in GNOME.
What is the video card/chip used?

While the discussion now seems to offer some solutions and understanding, this may look a bit off topic now, but this is nonsense. There is no panel at boot. There is only a panel after login into a GUI. I repeat “…f that are the Notifications popping up from your KDE panel, then that has nothing to do with boot …”.

Indeed, disabling the installer flash drive (USB-Verbatim) removes all other notifications. Thanks for the tip!

Thanks for reporting back on this.