kde - unison will not sync

Hello all.

Unison will not work. I’m syncing between main drive (linux) and a flash drive (ntfs).

It used to work. Now it’s saying properties don’t match. I can’t sync the properties. So, I can’t sync the music folder.

Need help.

Check the properties of the Unison profile you are using. You will need, in the profile editor window, fat boolean true on its own line. If it is not in there, you need to add it (with the Add button, of course).

The other problem that could occur: You need to mount the NTFS from the user account you run Unison in, and you also must make certain that same User owns or has proper access permissions for the music folder and files on the system.

Bottom line: The person running Unison must have adequate and matching rights on both sides of the sync path. The fat boolean entry will skip trying to sync the permissions, needed because the Linux permissions are not compatible with the NTFS permissions.

That worked. :slight_smile: Thanks.

Another old problem, it keeps noting a folder is a symbolic link. I finally found it. Last problem solved.

I found the symbolic link and deleted it. Unison rescan won’t get rid of it. Deleting profile and starting over didn’t work. ??

New problem. I’ll add a new post. Thanks to all.

FYI, I forgot to delete both links on the sync devices. Once, I deleted the other. Unison worked.

Thanks for the help.

You’re welcome, glad you have it working.