KDE terminal spontaneoulsly resizes

opensuse v12.3
KDE 4.10.00 r1

I have recently started using KDE (Gnome is having a peculiar problem with mouse movement). It’s different.

One problem is that the Terminal Window resizes (a la animation) to the size of postage stamp whenever it opens or a setting is changed. The preset size is 132x43 characters. The size starts there upon open, and immediately shrinks to uselessness.

Is there a way to prevent this ridiculous resize?

> preset size is 132x43 characters

characters or pixels?
and please tell how you preset it?
did it act ‘normal’ before it was preset to a certain size?

and when you write “terminal” are talking about Konsole, X-term,
Yakuake, LXTerminal, Terminal - Superuser Mode, Gnome-Terminal, one
of the terminals at Ctrl+Alt+Fn (with n = 1 to 6), or one of the
other several available terminal programs?

are the symptoms different if you turn off desktop effects…if so,
what is your graphic setup and driver?


dd
openSUSE®, the “German Engineered Automobile” of operating systems!

Characters.

and please tell how you preset it?

From the menu bar I select “Terminal” then “4. 132x43”. Also, in the settings Edit :: Profiles :: Default :: General I have enabled “Use custom default terminal size” which is set to 132x43.

did it act ‘normal’ before it was preset to a certain size?

I do not know. I had rarely used KDE prior to v12.3. I do not recall the size shrinking spontaneously, though, on previous occasions.

and when you write “terminal” are talking about Konsole, X-term, Yakuake, LXTerminal, Terminal - Superuser Mode, Gnome-Terminal, one of the terminals at Ctrl+Alt+Fn (with n = 1 to 6), or one of the
other several available terminal programs?

Gnome Terminal.

are the symptoms different if you turn off desktop effects…if so, what is your graphic setup and driver?

I changed to using Konsole. No resize issues there.

Thanks.

> Gnome Terminal.

i don’t have one of those…so, lets wait and see if anyone can
duplicate when running that terminal in KDE…

as far as Konsole, my experience is if you just grab a corner and set
the size you want, it will “remember” and open the same size next time…


dd
openSUSE®, the “German Engineered Automobile” of operating systems!

That does not help you now, but just to confirm I installed now
gnome-terminal on a KDE system in 12.3 and when I start it it starts
with a reasonable size and shrinks animated to a ridiculous small size
directly after it opens, never seen that before in earlier openSUSE
versions where I often had both KDE and Gnome installed.
I try to find out what that is, but do not expect too much.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.0 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

Seems to be around for a while
https://bugzilla.redhat.com/show_bug.cgi?id=707664
can you try comment 15


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.0 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

On 04/15/2013 10:54 PM, Martin Helm wrote:
> can you try comment 15

heh…desktop effects! (in my para 3)


dd

I have noticed that with gnome terminal. And even if I enlarge (or maximize), there is no prompt to enter a command.

I have noticed something similar with another gnome command, though I have forgotten which.

It seems that some gnome commands are not fully compatible with KDE.

On my system, I see that I have available:
xterm
Konsole
Linux 32-bit Terminal (seems to be xterm)
xfce terminal
lx terminal
Gnome terminal

Only Gnome terminal gives me problems. The others behave sanely.

My advice: try a different terminal program.

I am currently using “Konsole” for a terminal that I keep open for a long time, and “xterm” when I need something for short-term use.

On Mon, 15 Apr 2013 18:56:01 GMT jimoe666 wrote:

> Is there a way to prevent this ridiculous resize?

You have to create a window rule for konsole in the system settings.
There you change size to your favorite and deactivate maximize and
minimize at startup. Sorry, if the names be wrong becuase i’m looking
on a german version. But a search with “kde konsole window rule” find
better explanations than mine.

On 04/16/2013 06:44 AM, Ferenginar wrote:
> create a window rule for konsole

the op is not using Konsole…instead gnome-terminal, as reported in
post #3


dd