KDE System Tray

Hello, Im having a problem with KDE, i cant see any icons on my system tray.

For example Pidgin is running but theres no icon on the bottom right corner where tray is.

This is with KDE 4.5.5.


Sounds like you may have removed your Task Manager Widget and just need to add it back. Check your Task Bar settings and look at adding back in a Task Manager Widget.

Thank You,

No, hehe its there. Its just empty, although, when i hover over it, i can see klipper and some other stuff is invisible in tray.

Re-select your icon theme in Personal Settings > … > Icons (or ‘kcmshell4 icons’).

Tried changing the Icons Theme with no success, same icon on the tray, no pidgin, etc.

Tried changing the Icons Theme with no success, same icon on the tray, no pidgin, etc.

Oh, just launched Amarok, and i CAN see it on the tray, weird… pidgin is running but no showing in tray…

PD: Could the problem be that i installed Pidgin from an XFCE contributor repository?

Maybe you just need to start a new session?

I had something similar happen to me (with system tray icons) after a major update (from KDE4 factory). Anyway, the next day it turned out all I needed to do was update the marble package

zypper up marble

Got the latest Marble package from the KDE repository.

As Lord_Emsworth suggested, have a look at the session management settings (via System Settings). Make sure ‘Start with an empty session’ is selected. Click ‘Apply’, then logout and back in again.

Another thought: It might also pay to check that you haven’t got any conflicting repos enabled. Then try updating with ‘zypper up’ again (in case some updates missed).

Sorry for the long delay, i was gone a month on vacations !! hehehe

Well, tried the “start with empty session” and it didnt make any difference.

Run a full update, and post back.

Already have the latest packages from /repositories/KDE:/Release:/45/openSUSE_11.3/

Can we see your configured repos?

zypper lr -d

I’m running KDE4.6 now (from factory). Maybe worth upgrading to that perhaps…

#  | Alias                   | Nombre                  | Activado | Actualizar | Prioridad | Tipo   | URI                                                                       | Servicio
1  | kde                     | kde                     | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/ |         
2  | kernel                  | kernel                  | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/openSUSE_11.3/   |         
3  | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | No       | No         |   99      | yast2  | cd:///?devices=/dev/sr1                                                   |         
4  | packman                 | packman                 | Si       | Si         |   99      | rpm-md | http://packman.unixheads.com/suse/11.3/                                   |         
5  | repo-debug              | openSUSE-11.3-Debug     | No       | No         |   99      | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/            |         
6  | repo-non-oss            | openSUSE-11.3-Non-Oss   | Si       | Si         |   99      | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/              |         
7  | repo-oss                | openSUSE-11.3-Oss       | Si       | Si         |   99      | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/                  |         
8  | repo-update             | openSUSE-11.3-Update    | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/update/11.3/                                 |         
9  | xfce                    | xfce                    | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/X11:/xfce/openSUSE_11.3/        |         
10 | xorg_1                  | xorg                    | Si       | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.3/        |         

Ok, repos look fine. It’s likely that the KDE upgrade clobbered some configuration file in ~/.kde4/share/config/ (You could try renaming this directory, then log out and back in again. (Your desktop settings are stored here, so you can recreate if necessary).

  1. Does this affect KDE apps or just non-KDE apps?

  2. Try setting up a new user account. Does the system tray problem remain?

Renaming the folder you mentioned solved the problem !!!

Thanks !

Good result. Thanks for the update :slight_smile: