KDE support for Private XMPP Server chatting

I would like to use a kde client with a private xmpp server, but I haven’t had luck with kopete or telepathy, spark and pidgin work for me though.

Any suggestions?

Well, Kopete works for me, at least for chatting and file transfer. Never
tried the jingle extension.

I never tried telepathy, but maybe I can help with Kopete, if you describe
your problem …

Yeah, I can use Kopete and “telepathy-kde” to connect with Google Talk fine. But when I try to connect through XMPP and put a private server address it never resolves. My company has an Ignite Spark server, so I can use the Spark linux client fine, and I can very easily put in my credentials and server info into Pidgin. But when I try the same in Kopete it never connects.

I appreciate any troubleshooting help.

Well, I use ejabberd on a private server and it works with Kopete.

Did you try Kopetes XML console for the connection??

I’m not familiar with the XML connection, but happy to try. Can you point me how to start that setup?

Just configure your jabber account in Kopete. (Disable connect now)
Close configuration dialog and click at the right bottom of your main
window.
Kopete should show you your accounts.
Right click at the jabber account. There should be something like “XML
console” in the context menu.
Now, try to connect to the server.

The XML console shows all data exchanged between server and client.
If the console stays empty, we have to dig deaper …

Here’s what I got:

<?xml version="1.0"?>

<stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="domain.org">

<?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="dc2" id="17a600f4" xml:lang="en">

<iq type="get" to="domain.org" id="auth_1">
<query xmlns="jabber:iq:auth">
<username>username</username>
</query>
</iq>

<iq from="domain.org" type="error" id="auth_1" to="dc2/17a600f4">
<query xmlns="jabber:iq:auth">
<username>username</username>
</query>
<error type="modify" code="400">
<bad-request xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>
</error>
</iq>

I’ve also found these threads out there:
Kopete can no longer connect to Openfire Jabber server • KDE Community Forums
https://bugs.archlinux.org/task/19175?project=1&string=psi

There is also a KDE Bug report: https://bugs.kde.org/show_bug.cgi?id=221533
Strange, that nobody fixed it for almost 2 years by now.