KDE - Stuck at 640x480 resolution


I got an old (really old!) PC connected with VGA to my 2560x1440 monitor. I know VGA doesn’t quite reach that resolution but I’d like to be able to use 1920x1080 at least.

Initially the highest resolution I could select under KDE’s System Settings > Display Configuration was 800x600.
Figuring installing the NVIDIA-drivers would probably resolve this and I want them installed anyway I installed them, one restart later and now my resolution is stuck at 640x480, a step in the wrong direction!
Googled around a bit and found instructions on how to edit GRUB_GFXMODE in /etc/default/grub so I ran

kdesu kate /etc/default/grub

and changed ‘GRUB_GFXMODE=“auto”’ to ‘GRUB_GFXMODE=“1920x1080”’. Then I was supposed to run “sudo update-grub” but got a “command not found” but after reading some more and some trial an error I ran

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

which hopefully did the same thing, rebooted… and nothing improved.
Read elsewhere that selecting the resolution in YaST > System Bootloader > Kernel Parameters > Graphical Console might do the trick. But it’s already set to 1920x1080 there. (And goes all the way up to 2048x1536 even which I think is where VGA tops out at).

Some other forum post here where someone had a similar problem was asked to run

/usr/sbin/hwiinfo --gfxcard

which for me outputs:

HPPC@localhost:~> /usr/sbin/hwinfo --gfxcard
08: PCI 0d.0: 0300 VGA compatible controller (VGA)
  [Created at pci.386]
  Unique ID: qnJ_.KhsZnhCvVk0
  SysFS ID: /devices/pci0000:00/0000:00:0d.0
  SysFS BusID: 0000:00:0d.0
  Hardware Class: graphics card
  Model: "nVidia GeForce 6100 nForce 430"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x03d0 "GeForce 6100 nForce 430"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x2a6c
  Revision: 0xa2
  Memory Range: 0xfb000000-0xfbffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xfc000000-0xfcffffff (rw,non-prefetchable)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 7 (no events)
  I/O Port: 0x00 (rw)
  Module Alias: "pci:v000010DEd000003D0sv0000103Csd00002A6Cbc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: nv
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #8

Which doesn’t tell me much but hopefully adds some valuable info to my post.
I cannot use anything other than VGA as this motherboard (M2N68-LA) only has one graphical output, a vga port.

The monitor works fine, there’s 2 other PCs hooked up to it. One with openSUSE tumbleweed over DVI and one with Windows over displayport both doing whatever resolution I want them to (anywhere from 640x480 to 2560x1440).

Running xrandr I get:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480       73.00*


If you’re using X11/X.Org (possibly a good idea with older hardware – I’ve tried Wayland on this quite new machine and, went back to X11/X.Org for more than a few reasons) then, take a look at possible settings in the configuration files located in ‘/etc/X11/xorg.conf.d/’

  • “man 5 xorg.conf” explains all the gory details of setting up the graphics.

The Xorg log files located in ‘/var/log/’ will also give some hints as to what needs to be defined – successively restarting the systemd Display Manager will help to track the results of setting up the X.Org graphics parameters.

Install inxi and post

inxi -aGSz

Use CODE tags.

IMHO the best way is in using ATI Radeon HD 2000 series or newer video card.
Nvidia VGA output is too bad always.

I’m pretty sure your IGP hasn’t been supported by any proprietary NVidia driver since 304.x. What installing it did was disable competent FOSS drivers, forcing fallback to VGA crudeness. The proprietary drivers need to be purged according to the official directions provided for installing them if you wish standard FOSS drivers to be able to do their job.

Have you checked in BIOS to see the VGA RAM setting? Likely it needs more than the default to reach 1920x1080(x24/32bit) resolution.

For the FOSS drivers to work with GeForce 61xx iGPU in 15.3, kernel-default-extra needs to be installed, if it hasn’t been already.

Here, with the same IGP device ID as OPs, 1920x1200 is not a problem, while my 2560x1440 cannot accept its ancient analog VGA output to try for more, even using an adapter to its DVI input:

# inxi -GSaz --vs
inxi 3.3.21-00 (2022-08-22)
  Kernel: 5.3.18-150300.59.90-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: root=LABEL=<filter> ipv6.disable=1 net.ifnames=0
    noresume mitigations=auto consoleblank=0
  Desktop: Trinity v: R14.0.12 tk: Qt v: 3.5.0 info: kicker wm: Twin v: 3.0
    vt: 7 dm: 1: TDM 2: XDM **Distro: openSUSE Leap 15.3**
  Device**-1: **NVIDIA C61** **GeForce 6150SE nForce 430**] vendor: Micro-Star MSI
    **driver: nouveau** v: kernel non-free: series: 304.xx status: legacy (EOL)
    last: release: 304.137 kernel: 4.13 xorg: 1.19 arch: Curie
    process: 90-130nm built: 2003-13 ports: active: VGA-1 empty: none
    bus-ID: 00:0d.0 **chip-ID: 10de:03d0** class-ID: 0300
  **Display**: x11 **server: X.Org** v: 1.20.3 **driver: X: loaded: modesetting**
    unloaded: fbdev,vesa alternate: nouveau,nvidia **dri: nouveau** gpu: nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 108 s-size: 451x282mm (17.76x11.10")
    s-diag: 532mm (20.94")
  **Monitor**-1: VGA-1 model: NEC EA243WM serial: <filter> built: 2011
    **res: 1920x1200** hz: 60 dpi: 94 gamma: 1.2 size: 519x324mm (20.43x12.76")
    diag: 612mm (24.1") ratio: 16:10 modes: max: 1920x1200 min: 640x480
  **OpenGL: renderer: NV4C** v: 2.1 **Mesa** 20.2.4 **direct render: Yes**

Going by the tooltip in KDE’s Settings > Display and Monitor > Resolution tooltip I’m using wayland.
"‘640x480’ (4:3)’ is the only resolution supported by this display.

Using unsupported resolutions was possible in the Plasma X11 session, but they were never guaranteed to work and are not available in this Plasma Wayland session."
I vaguely remember messing around with Xorg on a similar board on the same monitor ages ago so that might be a path worth pursuing.

Even the cheapest of cheapest graphics cards on the used market would comparably be a rather massive investment for a system this old barely having any value to begin with. So I’d rather use the hardware at hand which should be ‘fine’, it just seems to be the software side of things preventing it from working.

inxi -aGSz:

  Kernel: 5.14.21-150400.24.18-default x86_64 bits: 64 compiler: gcc v: 7.5.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150400.24.18-default
  root=UUID=ffe5655a-78cc-4d8a-886a-e7dc5bbe919b splash=silent
  resume=/dev/disk/by-uuid/0f4f1a40-2231-45ea-9b9f-e932a8fb2e6e preempt=full
  mitigations=auto quiet security=apparmor
  Desktop: KDE Plasma 5.24.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 7 dm: SDDM
  Distro: openSUSE Leap 15.4
  Device-1: NVIDIA C61 [GeForce 6150SE nForce 430] vendor: Hewlett-Packard
  driver: N/A alternate: nouveau, nvidia_drm, nvidia bus-ID: 00:0d.0
  chip-ID: 10de:03d0 class-ID: 0300
  Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver:
  loaded: nouveau,nvidia unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 640x480 s-dpi: 96 s-size: 169x127mm (6.7x5.0")
  s-diag: 211mm (8.3")
  Monitor-1: default res: 640x480 hz: 73
  OpenGL: renderer: llvmpipe (LLVM 11.0.1 128 bits) v: 4.5 Mesa 21.2.4
  compat-v: 3.1 direct render: Yes

These integrated graphics support h264 hardware decoding which I was hoping to utilise, can this be done with the FOSS drivers?
All it really needs to do is do some youtube (probably with the firefox extension to force h264 playback) and local videos.

I can’t say I’ve ever heard or seen such a setting and there’s definitely nothing like that in the very limited HP BIOS of this particular board.

For the FOSS drivers to work with GeForce 61xx iGPU in 15.3, kernel-default-extra needs to be installed, if it hasn’t been already.

It’s installed.

I did a fresh install as apparently the disk I was using was on its last legs and I’m back on the FOSS drivers but I can’t say I’m impressed. Every time a windows gets drawn first the screen blacks out for a microsecond which makes for a very distracting experience.

Still no closer to getting a proper resolution out of it either.

Using the standard drivers also causes instabilities with the screen freezing up in some weird pattern at random that I didn’t have with the NVIDIA driver. So I think it’s safe to say that the default driver is definitely not the way to go.

See if adding ** nouveau.config=NvMSI=0** to your Grub linu line helps. If it doesn’t, try cutting back from full color to 64k/16 bit (via /etc/X11/xorg.con*: ‘Depth 16’ in ‘SubSection “Display”’ in ‘Section “Screen”’), a lighter weight DE than Plasma5, and/or disabling compositing (Option “Composite” “Disable”). That C61 chip seems to be NVidia’s example of the worst an IGP can offer. The one I have came from an owner that was using a discrete PCI (not AGP, not PCIe) card instead and who upgraded to a better motherboard and AMD APU, installation of which was done by me.