kde starting program

Hi
I’ve set cairo-dock to start but also kde somehow caches the desktop state while shutting down. Can I avoid cairo-dock to be cached at shutdown in kde?
Thanks
Michael

For clarification, are you saying you set cairo-dock to start, but it won’t because the previous state, that of not being started, is being cached by KDE at shutdown?

no i’ve set to start but cannot find to uncheck as it’s also started via kde.
So i’ve 2 cairo-docks instead of only one at each boot.
Best would be however to disable the kde start as this always asks about the opengl mode.

Try Configure Desktop -> Advanced tab -> Session Manager

Select “Start with an empty session”.

Thanks but I can’t find this. I only have gmenu or can i do that in the term?

Don’t have what? You are running KDE 4, yes? In any event, try running systemsettings in a terminal. Go to the Advanced tab, etc.

Great many thanks.