KDE reset and all files are missing

I was trying to get compiz fusion to work so I used the wiki on here. It said to update my ATI driver using this other wiki ATI - openSUSE. I went to ATI’s website and saw my card, Radeon X1650, on there, so I went on to the 1-click in stall for ATI driver. After the download, I logged out in order to run the commands listed in the wiki. After logout, it went to a blank screen. Couldn’t get into a different run level. I went to try and restart X using ctrl-alt-backspace, but hit ctrl-alt-del instead by accident. I’m not sure if that does anything, but anyway, the computer ended up restarting for some reason. Then after selecting opensuse 11.1 in GRUB, it would stop loading at some point and go to a blank screen.

I rebooted and went into failsafe and it asked me for login instead of starting X. I logged in as root and typed in the command

init 3

, a few lines popped up and then nothing happened. I don’t remember what the problem was. I ran

 SaX2 -r -m 0=fglrx

, it started a window, asked me if the configuration was okay, I hit yes and then it went back to run level 1. I tried

init 5

and the same thing happened that happened for init 3, pretty much nothing. Then I typed startx and when I got into kde, it was completely reset to default settings and all of my files that were in /home are now gone. I tried rebooting and it goes into this same desktop. What did I do to my computer? I didn’t use any formatting commands, so where are all my files?


Okay, I was panicking a bit when I saw all my files were gone, but then I remembered that earlier today I created a new account and I found out that SUSE had logged into that new account, which would explain the missing files and reset desktop. I switched users and my account loads unbearably slow. I couldn’t even use anything in it. I’ll look into that problem, but I just wanted to let everyone know to disregard my previous problem.