KDE problems - audio, login and usb - after reboot

Hi, I’m in trouble with openSuSE 13.1.

  1. Some days ago, after reboot, KDM won’t appear, I must log in to console and type “kdm & exit”. I tried GDM and LXDM, same problem.
  2. If I log as root, kmix and pulse audio works perfectly, but if I log as user, kmix tray icon says it can’t find the mixer. Running pulseaudio manually says "Failed to load module “module-esound-protocol-unix” (argument: “”): initialization failed.
    " Selecting an audio device from phonon and testing it says phonon is unable to set selected output device. Phonon lists some AD1989B audio devices, HDMI and one USB PnP. I usually switch from AD1989B to USB PnP (speaker to headset).
    Backend in use is GStreamer.
  3. USB keys asks for root password on mount.

I’m using KDE 4.13 and kernel 3.13.7-1.ga68bc7c-desktop.


  • Intel Q9650 4,25GHz
  • Asus Maximus II Formula
  • 8GB DDR2
  • AMD R9 290

I need your help, thank you in advance.

This is most likely related to KDM (or the orther display managers) not working, as it’s the display manager’s job to register the user’s session with logind.
This is necessary to get the necessary permissions to mount USB sticks and using PulseAudio.
And your point#2 sounds like a permissions issue as well, as it works fine as root.

So I guess we should first find out why KDM is not starting.

Could you maybe post the file /var/log/kdm.log after KDM failed to start? (maybe remove it first so it’s easier to find the current issue)

And maybe the X log would help as well.

Btw, what graphics driver are you using for your Radeon card?
The open source radeon driver that’s included in openSUSE, or the proprietary fglrx driver?
If the latter, which version and how did you install it? The latest stable version DOES NOT work with kernel 3.13 AFAIK. The openSUSE packages and Sebastian Siebert’s install script contain a patch for that though.

And have you tried with the standard 3.11 kernel included in openSUSE 13.1?

Removing .Xauthority solve the problem. After reboot pavucontrol can fix any audio problem.

Thank you :slight_smile: