[KDE Plasma on Wayland] sddm in Leap is broken

@asdhio no offence, but can’t you just use (as in download) the package(s) from the development repo, instead of linking and building (build power and storage)?

No can’t do. Factory doesn’t publish Leap packages, and neither does the development repo. If there is a better way to do it, I would be pleased to hear it, as linking and building takes more effort than necessary for me as well.

@asdhio They do…?
https://mirrorcache-us.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.5/
https://mirrorcache-us.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.5/x86_64/sddm-0.20.0-lp155.137.1.x86_64.rpm

1 Like

Huh? It is documented here…
https://en.opensuse.org/SDB:KDE_repositories#Adding_these_repos_to_an_existing_installation

Thank you. Apologies for the confusion, as I was not aware of these two options.
I tried the following, which didn’t work unfortunately. I thought it was the natural user-friendly way of doing it, but it appears it isn’t the case for development and Factory packages. I will try to use the mirrorcache link template and the “zypper ar -fp 75” command moving forward. Cheers

1 Like

Or just save the mirror-provided .repo file to /etc/zypp/repos.d/. No chance for typos that way.

The repo file mentioned by mrmazda is for PowerPC and not suitable for Leap 15.5. You need to to use the URLs provided in Deanos comment 5 or Malcoms comment 4

I was responding to the first release name provided in the image in the OP’s post which I was responding to (#5? post numbers here are clear as mud as to where the applicable post begins and ends, esp. when the editor window is open and less than half of screen height is available to ID posts endpoints). URL for 15.5 repo file is here. Each of the four Frameworks5 directories there has one of its own. :slight_smile:

Unfortunately, updating sddm to version 1.20 didn’t fix it.
To start the Wayland session of Plasma, I have to reboot my computer several times and try logging in from tty over and over again until it works. Sometimes removing the .cache folder helps, though I doubt it’s the main culprit.
Either way I can’t seem to be able to access sddm anymore, neither versions 1.19 or 1.20. Something has seriously broke and even restoring from snapshots prior to the issue doesn’t help.
Perhaps it’s worth mentioning that I’ve used to use a dual monitor setup before, and I still had to log in from tty sometimes, but now that I can no longer access the second monitor, the issue has worsened to its current state.

Just found a fix.

sudo rm /etc/systemd/system/default.target

The problem has been solved altogether. No more logging in from tty or not being able to log in at all.

Rather drastic. Do you know what you are doing? Do you still know what it was before you destroyed it?

@asdhio so likely set to multi-user.target rather than graphical.target… did you look first? Just running systemctl set-default graphical.target would have cleaned it up…

Quite honestly, the move was in desperation as nothing else worked.
I figured that if it made things worse, I could still rollback with snapper.
An old solution on OpenSUSE forums has also provided a similar solution:

I tried that but the issue persisted in one shape or another. I still had to run startplasma-wayland/startx from tty and sometimes it still wouldn’t work. Sddm was completely broken, even after reinstalling and upgrading to 1.20.

I also don’t know if the newer version of SDDM played any part in this, but I’m scared to downgrade it now, given that it didn’t work at all prior to running this command.

You still do not seem to understand what the situation was (multi-user target), what you did (and what you should have done) to set the situation to what you seem to want (graphical target).

True, but it shouldn’t have been an issue in the first place. The average user is not going to understand the difference between multi-user and graphical targets, let alone manipulate them to make them work.
I found a solution that worked for me with no negative side effects, and while it wasn’t the direct solution for the issue, it still worked, especially when compared to all the other commands that I used.

Well, it was. Your system was in multi-user mode all the time. And then of course no sddmor any other DM should start (and thus your conclusion that “sddm in Leap is broken”, was false).

The question still is why “For quite some time now” your system booted into multi-user mode. Some body set that and it wasn’t me.

In any case, even when you persist in not teaching yourself about (default) targets, my advice is to do (as root)

systemctl set-default graphical.target

to get everything in the same order as all others have it.

Hello again.
I downgraded sddm to version 1.19 through YaST.
As a result, it refused to boot again, throwing me into tty. “startplasma-wayland” did not work either.
Had to rollback to a working snapshot, everything works again.
I’m afraid my fears about SDDM being broken were correct, as 1.20 did, in fact, somehow contribute towards fixing the issue.