KDE Plasma freezes completely sometimes


for some reason, my desktop freezes completely sometimes. The only thing I can do then is to press the hardware reset button. So, the desktop freezes completely / hang up.
The issue persists over multiple Tumbleweed snapshots.

I posted the same question as an cross posting question here (in german): https://www.opensuse-forum.de/thread/64077-kde-plasma-friert-mit-opengl-sporadisch-komplett-ein/

My hardware:
Mainboard: ASRock 970 Extreme3 Revision 1
CPU: AMD FX-4100
hard disc drives: One mechanical HDD for /boot and PCIe M.2 Disc for /root, connected via PCIe 2.0 4x Adapter from i-tec. Booting from the M.2 disc is theoretically possible, but my doesn’t ship the required driver for that, so I need the initial boot sequence from an SATA disc. A custom BIOS would be possible, but ways too risky in my opinion.
graphics card: 4GB MSI Radeon RX 550 4GT LP OC active PCIe 3.0 x16 (x8) 1xDVI / 1xHDMI 2.0 (Retail)
sound card: Creative X-Fi Fatal1ty Professional Series (very old, but runs still fine - I’m able to get 4 to 9 ms ASIO latency with that card) via PCIe 2.0 1x

I’m just using the AMD graphics kernel module, that is shipped with the Linux Kernel.

My current Tumbleweed snapshot:

cat /etc/os-release
NAME="openSUSE Tumbleweed" 
# VERSION="20210208" 
ID_LIKE="opensuse suse" 
PRETTY_NAME="openSUSE Tumbleweed" 

The other requested commands from the cross posting:

/sbin/lspci -nnk | grep -EiA3 vga
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] [1002:699f] (rev c7)
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:8a90]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

glxinfo | grep -Ei "direct|libgl"
direct rendering: Yes
    GLX_EXT_import_context, GLX_EXT_libglvnd, GLX_EXT_no_config_context, 
    GL_AMD_gpu_shader_int64, GL_AMD_multi_draw_indirect, 
    GL_ARB_depth_clamp, GL_ARB_derivative_control, GL_ARB_direct_state_access, 
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect, 
    GL_ARB_indirect_parameters, GL_ARB_instanced_arrays, 
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect, 
    GL_AMD_multi_draw_indirect, GL_AMD_performance_monitor, 
    GL_ARB_direct_state_access, GL_ARB_draw_buffers, 
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts, 
    GL_ARB_indirect_parameters, GL_ARB_instanced_arrays, 
    GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect, 
    GL_EXT_copy_texture, GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,

uname -r

zypper se -s kernel mesa libgbm libdrm

see: https://pastebin.com/vWr1hwiY

And last but not least, the last journalctl log entries when it has happened:

journalctl --since "2021-02-10 21:00:00" --until "2021-02-10 21:35:00" --no-pager -p "emerg".."warning"

see: https://pastebin.com/MBWxyjBE

I’ve researched a lot those QT errors. But it seems to be Linux distribution independend, because I found it on Ubuntu i. e. as well. They guys there said that the questioner should change the operating system-wide QT version from QT Quick to the full QT framework version. But I don’t know which packages would affect that and if it’s even possible in Tumbleweed?

The issues appears in X11 and in Wayland KDE Plasma sessions. But I need X11 in order to keep polychromatic working (frontend gui software for Razer hardware - keyboard and mouse), because it can’t currently handle the stricter Wayland rules.

I would appreciate any help to that issue. I’m posting it here as well, with the hope of reaching an wider audience :slight_smile:

Thanks in advice,


Just to inform you guys:

As I read it from the syslogs, it seems to be a problem with KDE (some mishandled Threads between parent- and childwindow; it must crash that way with this mishandling…), I will try a few weeks GNOME in order to exclude KDE from that problem.

If it’s not that, when a collegue of mine told me, that it could be and graphics card defect. So, if GNOME freezes also, I will try a different graphics card for testing.

I think kernel panic can be excluded, because my keyboard wasn’t blinking at all lights when it had happened.

may or may not be related so…

on my leap15.2 install ( kde) it is a btfs issue
as i recall , the last time was a few weeks ago .

a btfs program was using all 8 of my cores and locking up the box to the point that i have to do a hard reboot

my file system is btfs( giving it a go) for the OS and ext4 for the rest of my system

might be something for you to look into

Thank you, I will keep that in mind.

But I don’t think that this is the problem here, because in syslogs you can clearly see an issue between QT parent- and childwindow. Maybe hard to find for the KDE project, because thread handling can be at some points very complex. So I guess I entered an rare case, which KDE wasn’t thought about.
So, I will try now long time GNOME and we will see if that works out for me.

The combination of btrfs for the system and ext4 for the other partitions is an great idea, because I only need btrfs on the system for snapshots. Snapshots on TW are really neccessary, if something will go wrong with the upgrade (as already had with a new kernel - more issues and system freezes than before).

Hello, I think I’m having a similar issue, these are the journalctl entries from the time interval in which I faced the freeze:

feb 26 14:10:59 t5600 plasmashell[1637]: **file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:464: TypeError: Value is undefined and could not be converted to an object** 
feb 26 14:10:59 t5600 plasmashell[1637]: **file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:379: Unable to assign [undefined] to QString** 
feb 26 14:10:59 t5600 plasmashell[1637]: **file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:379: Unable to assign [undefined] to QString** 
feb 26 14:10:59 t5600 plasmashell[1637]: **file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:464: TypeError: Value is undefined and could not be converted to an object** 
feb 26 14:11:06 t5600 kernel: **nouveau 0000:03:00.0: gr: TRAP ch 9 [007f5ca000 firefox[2094]]** 
feb 26 14:11:06 t5600 kernel: **nouveau 0000:03:00.0: gr: GPC0/TPC0/MP trap: global 00000004 [MULTIPLE_WARP_ERRORS] warp 3f0009 [ILLEGAL_INSTR_ENCODING]** 
feb 26 14:11:10 t5600 kernel: **nouveau 0000:03:00.0: fifo: SCHED_ERROR 0a [CTXSW_TIMEOUT]** 
feb 26 14:11:10 t5600 kernel: **nouveau 0000:03:00.0: firefox[2094]: channel 9 killed!**

Using KDE Plasma + X11 on a Nvidia Quadro NVS510 GPU
However I’m afraid that this is a different kind of issue, due to the nouveau driver being involved in the crash.
When these freezes happen, the only thing that keeps working is audio playback (which doesn’t stop) and the mouse cursor, which still moves.

Check it with Nvidia drivers in use + OpenGL 3.1 render.
With nouveau use XRender.

Thanks, I was using OpenGL 3.1 with nouveau. Switched to XRender, let’s see if it fixes the issue. Never tried the Nvidia drivers because the only time I tried to install them I destroyed my system. Will try again sooner or later, now that I have enabled btrfs snapshots.

To OP: possibly glitch happened during OS install/update.
Check it with a fresh installed OS.

Another option: disable KDE composer at all.