KDE Plasma desktop 5 - flickering screen

For some time now I have a problem with flickering screen at Plasma 5 (42.2). It looks like sometimes the screen has additionally issues with refreshing, which results in minimized windows still being visible until new content needs to be drawn on the screen. It’s all next to useless unfortunately. Here’s the captured behavior:


After a restart it works ok, problems start after a few minutes and can only be recovered with computer restart.
I tried Gnome 3 (I guess it uses 3D graphics as well) and I could not see such issues.

What diagnose info/logs might be valuable?

Share your graphics card details…

/usr/sbin/hwinfo --gfxcard
> sudo /usr/sbin/hwinfo --gfxcard
root's password:
30: PCI 105.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: ul7N.8gHwAY4U_sE
  Parent ID: vSkL.Phf8HiXVYRA
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
  SysFS BusID: 0000:01:05.0
  Hardware Class: graphics card
  Model: "ATI RS880 [Radeon HD 4200]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x9710 "RS880 [Radeon HD 4200]"                                                                                        
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."                                                                                      
  SubDevice: pci 0x83a2 "M4A785TD Motherboard"                                                                                       
  Driver: "radeon"                                                                                                                   
  Driver Modules: "drm"                                                                                                              
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)                                                                          
  I/O Ports: 0xd000-0xdfff (rw)                                                                                                      
  Memory Range: 0xfe9f0000-0xfe9fffff (rw,non-prefetchable)                                                                          
  Memory Range: 0xfe800000-0xfe8fffff (rw,non-prefetchable)
  IRQ: 18 (1577225 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00009710sv00001043sd000083A2bc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is active
    Driver Activation Cmd: "modprobe radeon"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)

See if this helps…

System Settings > Hardware > Display and Monitor > Compositor, change ‘Tearing Prevention’ to ‘Full screen repaints’

Perhaps worth experimenting with the rendering backend as well.


BTW, I should have mentioned that you may need to logout and back in again for this to take effect.