KDE plasma crashes in wayland session (nvidia card)

Hello Forum !
Opensuse tumbleweed user here !
I am facing a problem of KDE plasma wayland session not working. The same issue has been with Hyprland session.

I am using the nouveau drivers for my nvidia card (GT610) as G04 series (390.x.x.) drivers have reached EOL since end of 2022 . Use of nouveau has been suggested as per this post here
Tumbleweed is on kernel version 6.7.5 currently.

To summarize the problem -

  • Not able to login into the Wayland session on KDE Plasma as well as Hyprland.
    (though everything used to work fine when i installed tumbleweed a month ago and installing the egl-wayland package , but certain updates seem to break wayland support.)
  • The wayland session works only in Gnome environment with the nouveau drivers on tumbleweed.
  • X11 session works perfectly on all DE , even with the Nvidia drivers (390.157) installed.
  • Wayland session works on Kde plasma on fedora (kernel 6.7.5) using the nouveau drivers.
  • Yast software management modules prompts to install the G04 series Nvidia drivers even when the zypper automated installer scipt - zypper install-new-recommends --repo NVIDIA doesn’t install any nvidia drivers probably due to compatibility issues.

So , i am looking for a solution to run the wayland session on KDE plasma or Hyprland on opensuse tumbleweed.
I am unable to diagnose the problem and don’t know what exactly is at fault here ? nouveau ? kwin ?
Any help will be appreciated :slight_smile:

Are you using nouveau exclusively, or is the modesetting DIX display driver loaded instead of the nouveau DDX display driver? inxi -SGaz will show which is the case. Try switching to the other from whichever you have been using in conjunction with the nouveau kernel module, egl and dri. This pinned primer in Hardware explains the difference and switching methodology.

1 Like

thanks for your response , i tried to follow what you suggested . inxi -SGaz gives output driver=nouveau . So i tried to switch to modeseting Dix display as suggested by your linked post by uninstalling package xorg-x11-driver-video , xf86-video-FBDEV , xf86-video-VESA.
I did this from Yast. But on reboot it nothing seems to change .

Also i tried to install the nvidia driver 390.157 manually with patch for kernel 6.6 linked here but it too gave many errors which i couldn’t comprehend much.

xorg-x11-driver-video is a metapackage. Removing it doesn’t normally remove all the packages it initially installed. I expect xf86-video-nouveau remains installed, so either it would need to be specifically removed, or the modesetting DIX explicitly specified via /etc/X11/xorg.con*. e.g., this file /etc/X11/xorg.conf.d/15-modeset.conf would specify:

Section "Device"
  Identifier "DIX"
	Driver "modesetting"
EndSection
#
1 Like

The DDX driver is irrelevant in a Wayland compositor environment.

1 Like

Tried this but didn’t help either.
And yeah my issue is specifically related to wayland session as everything works fine in x11 session.

I tried to take more logs for the wayland session in Plasma kde , with nouveau drivers -
ksystemlog window shows following errors while trying to use wayland session.

kwin_wayland kwin_scene_opengl: Creating the OpenGL rendering failed: "Required extension GL_OES_EGL_image not found, disabling compositing"

The wayland session gets extremely laggy and give these errors.

You might get further diagnostic information using

dbus-run-session startplasma-wayland > wayland.log 2>&1

For others who might come searching re Hyprland and NVIDIA harware

1 Like

@deano_ferrari I had Hyprland running here on Nvidia, but normally have on Intel…
My config notes…

env = XCURSOR_SIZE,12
env = GDK_BACKEND,wayland
env = SDL_VIDEODRIVER,wayland
env = CLUTTER_BACKEND,wayland
env = QT_QPA_PLATFORM,wayland-egl
env = QT_QPA_PLATFORMTHEME,qt5ct

# For nvidia, see https://wiki.hyprland.org/Nvidia/#how-to-get-hyprland-to-possibly-work-on-nvidia
env = LIBVA_DRIVER_NAME,nvidia
env = XDG_SESSION_TYPE,wayland
env = GBM_BACKEND,nvidia-drm
env = __GLX_VENDOR_LIBRARY_NAME,nvidia
env = WLR_NO_HARDWARE_CURSORS,1
env = WLR_RENDERER_ALLOW_SOFTWARE,1
1 Like

Yep, that makes sense to me, but not sure that it is helpful to OP’s situation.

Post

inxi -SGaz
zypper se -si egl

I suggest to use ATI/AMD/Intel video card.

Confused as to why I had no issues with Wayland and Plasma5, but as soon as I upgraded to Plasma6 Wayland no longer work, crashes on start, x works just fine tho. Running an RTX 4080 with proprietary NVIDIA drivers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.